Support » Plugins » Hacks » Putting a default table in the editor

  • Resolved jsteez


    I’m building a wordpress page for a friend of mine. It’s a musicvideo-blog where he places new youtube musicvideo’s every day with a small text about the artist/song.

    Everything is working correctly but I can’t figure out the text wrapping. I want the embedded youtube video appear on the left and the text on the right side of it.
    My solution was placing a two column table with html in the post, where i put the video in the left column and the text in the right one.
    The problem is that my friend doesn’t understand anything about coding and wants a quick way of placing new posts without the hassle of setting up a new table for every post.

    So my question: Is it possible to ‘hack’ the editor i a way that there’s always a default table with the correct sizes in the editor?
    I know using tables is a bit outdated but I guess if it would work for tables it will also work for divs?

    PS. I’m using Viper Video Quicktags for embedding youtube video’s.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Yes – layout tables are terribly outdated. If you used CSS, you could just try floating the embed and/or object elements left with a reasonable right-hand margin.

    Thanks for your quick reaction. I did read something about that:

    It works great with images but I don’t think it’ll work for the VVQ-plugin. it uses [youtube] quicktags. So what’s the right way of adressing this in CSS?

    By floating the embed and/or object elements left with a reasonable right-hand margin. You style on the page output – not on the page’s shortcodes. Start by looking at what is being generated in the final page.

    Of course, I’m such an idiot 😛

    I looked at the page-source, I noticed the video’s are put in a div class vvqbox by the Viper Plugin. So I thought I could easily add the float:left by hand. Turns out that there’s even a setting in the plugin to do this.
    So it finally works. Sorry I bothered you when the solution was just a simple setting, but I’ve been trying to get this right since this morning. this topic is solved!

    Sometimes it takes another set of eyes. 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Putting a default table in the editor’ is closed to new replies.