WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Pulling in Magento Block error

[Resolved] Pulling in Magento Block error

  • I have a magento enterprise 1.13 currently loosely integrated with WordPress 3.8.1. I am using the Magento integrator and shortcode add on.

    I am able to get products over without a problem but when I make the call to get the block, it freaks out and throws errors. If I flush the cache, delete cookes and reload the page, there are still errors on the page but the block shows up. If I navigate to another page, I get the errors and not block yet again. Here are the errors/debug details.

    <br />
    Strict Standards: Redefining already defined constructor for class jck_mwi in /www/sites/www.xyz.com/files/html/liveit/wp-content/plugins/magento-wordpress-integration/mwi.php on line 204 Strict Standards: Redefining already defined constructor for class jck_mwi_shortcodes in /www/sites/www.xyz.com/files/html/liveit/wp-content/plugins/mwi-shortcodes-widgets/mwi-shortcodes-widgets.php on line 51 Strict Standards: Redefining already defined constructor for class jck_prod_widget in /www/sites/www.xyz.com/files/html/liveit/wp-content/plugins/mwi-shortcodes-widgets/mwi-shortcodes-widgets.php on line 84<br />

    Everything appears to be set up correctly. I do have this functioning correctly on another website on the same server (different directory) but for some reason, this issue is occurring.

    https://wordpress.org/plugins/magento-wordpress-integration/

Viewing 3 replies - 1 through 3 (of 3 total)
  • I pretty much figured out the issue. Based on the recommendation in another thread, i uninstalled the plugin (again) and removed all the references in the database as well.

    I rechecked the function.php file in my copied app/code/core/Mage/Core/functions.php file. I then turned off all of my plugins and switched to the default 2014 template.

    Once I set my plugin options to the Mage.php directory, it did work like a champ. I then turned on my custom theme and that’s when it broke. Although I tried this before, I think there were some broken references during installation so I didn’t catch this when I tried the default theme the first time.

    Bottom line, sessions were the killer. I am using the Gantry framework to build a custom template and it uses sessions for all sorts of things. Unless someone figures out how to make these two coexist, I’ll be using another framework to build my template.

    I know no one chimed in on the thread but hopefully it helps someone else out there using Gantry that may also be using this plugin.

    Plugin Author jamesckemp

    @jamesckemp

    Hi,

    Glad you’ve figured out the issue. Unfortunately, a session cannot be started if you want to include Magento in this way. I’ve found no way around it!

    I may add a feature to disable Magento sessions, if cart and customer data are not required. Or maybe I could find a way to do it via Ajax so the session is never loaded on WP frontend. I’ll have a think! keep an eye out.

    James, is there any way I can disallow sessions for WP and Magento as of now? I really only need the products and newsletter.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Pulling in Magento Block error’ is closed to new replies.