WordPress.org

Support

Support » How-To and Troubleshooting » publishing thru xmlrpc doesnt work

publishing thru xmlrpc doesnt work

  • Hello,

    I have updated my wordpress version to 3.3.1 , I cant seem to register any accounts from MS Office.

    I have enabled xmlrpc under Settings – Writing , also xmlrpc is reacheable on http.

    I have enabled logging/debugging but I couldnt get anything relevant:

    2012-04-01 10:10:59 Input: <methodCall><methodName>blogger.getUsersBlogs</methodName><params><param><value><string></string></value></param><param><value><string>user</string></value></param><param><value><string>userpass</string></value></param></params></methodCall>

    2012-04-01 10:11:05 Input:

    2012-04-01 10:11:06 Input:

    2012-04-01 10:11:06 Input:

    I am running it under lighttpd 1.4.30 / php 5.3.10 .

    Any feedback on this would be much appreciated.

    Thanks !

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi, I have been trying xmlrpc too on 3.3.1 blogs of mine and also getting issues. Same just wont connect, tried all sorts of options.

    Any tips or help please?

    p.s. also found this related post http://wordpress.org/support/topic/better-wp-security-breaks-xml-rpc?replies=2 I will cross link from there to here

    but no solution yet

    Unfortunately I had no luck in solving this until now, it looks like there might be indeed a bug in the xmlrpc service, alot of the code has been moved away. I could not get it to give any error so I am assuming there is something wrong in one of the included class files.

    Maybe we will get lucky and some wordpress developer takes a peak at this..

    Hi Guys

    If you’re using Better WP Security and can’t update using WordPress iOS try turning off this BWS option in your WP dashboard:

    Security > Tweaks > Server Tweaks > Filter Suspicious Query Strings

    I’ve got everything else selected in BWS. But turning this option off solved several other problems with my themes as well.

    I’m able to use WordPress iOS again. And my theme works. Hope this helps.

    Regards – Dennis

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘publishing thru xmlrpc doesnt work’ is closed to new replies.
Skip to toolbar