Support » How-To and Troubleshooting » Publishing takes a long time

Publishing takes a long time

  • Saving articles as drafs takes no time. But when I actually get around to posting the article it can take up to 5 minutes before it processes. I’m only pinging pingomatic.

Viewing 14 replies - 1 through 14 (of 14 total)
  • What version of WordPress? Anything less than 1.5/1.3 should look at http://weblogtoolscollection.com/archives/2005/02/24/wp-12-slow-posting/

    I’m using 1.5

    Moderator James Huff


    Go to Options/Discussion, do you have “Attempt to notify any Weblogs linked to from the article (slows down posting.)” selected?

    I have the same problem, using 1.5, and that option you mention (macmanx) was the first thing I turned off…

    After testing this a whole bunch (I’m re-categorizing posts, and therefore need to re-save them), I found that for posts with many links in them, the 5-minute+ problem occurs. When re-saving posts with only text or pictures (but no links), the posting is very quick as it should be.

    I’ve removed all ping URLs in the update notification box, and it seems to help very slightly – but we’re talking about a 30 second difference here.

    It’s almost as if even though the option to “notify any weblogs linked…” is not checked, WP 1.5 *still* thinks that it is, and does it anyways.

    Does anyone have any other idea why this is happening? Or maybe a workaround? At 5+ minutes a post (btw, that’s a conservative estimate!), I’ll be re-categorizing for the next few months!


    Surely there must be some way to fix this problem… It can’t be normal to have to wait so long for certain types of posts. At least, are other people experiencing the same thing?

    Yes, I had a post with object tag for Flash, no links, and it was really slow until I turned of “Attempt to notify”

    “I’m only pinging pingomatic.”

    Are you aware pingomatic attempts to ping 18 different sites with each post? Plus those linked to in your post if you have “allow pings” checked.

    I’m also using 1.5 and I’ve noticed this (not 5 minutes, but still quite long) for posts with links. I’ve also turned off all the auto-notify stuff, (and I *don’t* ping pingomatic) but it doesn’t seem to help. More links definitely means more waiting.

    When I clicked Save or Publish my Firefox would sit in limbo (with spinning thing) and never reload to a fresh page… but the post would update immediately. Deleting pingomatic (Options>Writing) worked for me… for now…Thanks.

    same thing here and i too am using firefox… i have the newest version of wordpress too… this just started to happen here recently…before it was fast, only a couple seconds tops… everything else is still fast… i thought it was just mine, but then i saw this thread… i wonder what it is?

    Options -> Discussion -> Uncheck “Attempt to notify any Weblogs linked to from the article (slows down posting.)”

    @ Viper007Bond

    but why, even with that option checked, was it fast before but slow now? This isn’t an isolated case since so many people are experiencing this, so there must be something causing it. Could it be something in the dashboard? Thats the only thing that I can think of thats common in most people’s blogs. Doesn’t the dashboard import data?…

    …..I uchecked all those things…just made a post and again, it just sat there and took forever for the page to redirect like normal… i wonder what is going on…

    Things seemed to have sped up all of a sudden… hmmm… i wonder what it was that did this to everyone’s blog…

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Publishing takes a long time’ is closed to new replies.