Support » Fixing WordPress » Publishing post problem

  • Resolved crgianotti


    Sometime when I try to publish or update a post, when I click “publish”, the screen comes back and says, “Page not found (404)” When I remove some of the text in the post, then it publishes find. I tried to narrow the text to see if some text in the post was somehow causing the problem, but it seemed erratic. At one point if I removed the word “from” then the post would publish. If I put it back in, the post wouldn’t publish. I have looked into the HTML, but no weird codes there. I have typed the text in the visual screen and also the HTML screen, but problem continues. I do daily posts, an this happens maybe once every 5-10 posts.
    Any body have this problem or similar?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Check with your host about the mod_security extension. I’ve seen this before, and generally it’s that causing headaches.

    They SHOULD be able to change some settings for you.

    You may need to point them to this:

    Thanks. I’ll check with my host.

    Did that fix the problem?

    It isn’t intermittent with me. Posts publish and update but always return “Page not found.”

    Also, posting is taking much longer, but that started a bit before this “Page not found” issue.

    I guess I could turn off auto-notifying search engines with every update and then test plugins one at a time. Ugh.

    My web-host/provider is familiar with the problem and did some rooting around on the mod-security extension – he changed some things. All seems to work well now, however since it was intermittent, time will tell.

    Thanks for the reply. I can post, but nothing refreshes as it used to. If I use the quick edit features on the Edit Posts page for instance, the edits will work, but the page will just sit there with the “working” indicator spinning as if it’s still working on it. When I go to the full editor and update, the update works, but it never reloads the page. If it’s a new post and I publish it, it goes to a blog page where only my sidebars are showing. Publishing works, but all these things are annoyances of course.

    I’ll see if my provider can tell me if mod-security extensions have changed recently and/or if they know if/how that could be an issue in my case.

    Ah, after a quick search, I ran into this: “Unfortunately mod_security is not available on shared hosting accounts.” I’m on shared hosting.

    If anyone has any other ideas, I’m all ears/eyes.

    Thanks again.

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterPost Off

    in the .htaccess worked for posts, but I haven’t checked the comment aspect yet. If it works, I won’t come back to say so. I’ll only return to say what’s still not functioning.

    I guess GoDaddy enabled mod_security on shared hosting without letting me know.

    The Hyper Cache plugin cache directory was way overloaded too. Clearing it seemed to help. I’ll have to monitor that to see if it was really part of this problem though.

    One should think WordPress would be coded to accommodate mod_security hiccups, but that’s probably easier said than done.

    Making the mod_security change did help, but it did not completely solve the problem. It turned it into an intermittent problem narrowed to publishing/updating rather than saving drafts too and other actions.

    It’s annoying and definitely is a WordPress version issue. I never experienced it before the last (two?) versions. As of this comment, WordPress is at version 3.1.

    I was wrong. It wasn’t a WordPress-version issue, per se, unless one counts a new version of WordPress that breaks a plugin a WordPress-version issue. I don’t.

    So, it was the “Global Translator” plugin, version 1.3.2.

    Deactivating it solved my problem.

    I like that plugin. I hope an update comes out for it soon.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Publishing post problem’ is closed to new replies.