Support » Everything else WordPress » Publishing post also triggers “Post Update” in Gutenberg editor

  • Resolved sarangsss29

    (@sarangsss29)


    Description
    So I am seeing a weird issue lately while publishing a new post. Publishing post using Gutenberg Editor also triggers Post Update function causing (post) published and (post) updated date duplicates.
    This does not happen with Classic Editor.

    Step-by-step reproduction instructions
    Go to ‘Add new post’
    Click on ‘Publish’
    It immediately starts “Updating….”

    Expected behavior
    Should only publish and not trigger post update.

    Actual behavior
    Publishes the post and starts updating it.

    Screenshots or screen recording
    Screenshot: (from production site)
    http://prnt.sc/10kh53j

    Video: (from staging site)
    https://d.pr/free/v/QwAHBv

    Using Classic Editor
    http://prnt.sc/10kl2zm

    WordPress information
    WordPress version: “5.6.2” & “5.7”
    Are all plugins except Gutenberg deactivated? “Yes”
    Are you using a default theme “No” Using “Aquene” theme

    Device information
    Device: “Desktop”
    Operating system: “Windows 10”
    Browser: “Chrome 89”

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi, @sarangsss29

    Thank you for such an elaborate description of the issue you are facing.

    First, showing Updated: date is 100% controlled by your theme. The default theme Twenty Twenty One does not come with this feature, so I had to add it, in order to try and replicate your issue. I used the code provided here: https://www.wpbeginner.com/wp-tutorials/display-the-last-updated-date-of-your-posts-in-wordpress/

    The code above checks if there is a day between modified time and published time, and then it displays the modified date. I don’t know how your theme handles that. Maybe there’s something wrong there.

    That being said, I couldn’t replicate your Gutenberg editor experience.
    As you can see here, I only get Publishing… and not Updating…
    https://youtu.be/8M44T_dCmnk

    I tried this with and without Gutenberg plugin active.

    All of the above concludes that your theme might
    – hook up to the Publishing process
    – have a logic problem when displaying or not the Updated on field.

    Unless you can replicate the issue in Gutenberg with a default theme, this is not a WordPress itself issue, but a theme related thing.

    Since you use a commercial theme (Aquene), please go to their official support channel. We feel they are best equipped to support their products.

    https://themesharbor.com/contacts/

    Forum volunteers are not given access to commercial products, so we would not know why your commercial theme is not working properly. Commercial products are not supported in these forums.

    Hope this helps,
    Kind regards!

    Thread Starter sarangsss29

    (@sarangsss29)

    Hi @vladytimy
    Thanks for the reply. I figured it out. It is the
    AddToAny Share Buttons Plugin
    https://wordpress.org/plugins/add-to-any/
    I finally figured it out. I have deactivated the plugin and will never use it.

    Sorry for the trouble, and thanks for the reply. I should have extensively tested the issue before creating a thread.

    • This reply was modified 10 months, 2 weeks ago by sarangsss29.

    No worries! I’m glad you found the culprit plugin. Actually, you did quite a lot of debugging before posting here so, that helped a lot!

    If your problem has been solved, we would love if you would mark this topic as resolved in the sidebar. This helps our volunteers find the topics that still need attention and more people will get helped, possibly like you did.
    Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Publishing post also triggers “Post Update” in Gutenberg editor’ is closed to new replies.