Support » Networking WordPress » Publishing failed. You are probably offline.

  • Resolved mauricev2


    I have a multisite installed with one site having been imported with the WordPress importer. When I try to create a new page and publish it in the imported site, I get this error

    Publishing failed. You are probably offline.

    The error is specific to just this site, which seems odd. I can publish no problem in the other two sites.

Viewing 15 replies - 1 through 15 (of 30 total)
  • Thread Starter mauricev2


    What’s going on is that when I create or import a site for some reason, at least some of the time, the site is saved with the URL beginning with http and not https. When creating a new page, WordPress references it using http and the browser blocks mixed content causing the update to fail with the message that the site may be offline.

    This appears to be a bug, but it’s not clear why others haven’t reported it. Reported as

    I’m faced with a problem

    This is related to the site network setup.

    It was happening to me also but when I went to network admin and manually updated the site url to https it started to work correctly. Don’t know why but when creating a site wordpress is saving with http and not https.

    thank you @wemago you have given me the solution – once i had replaced all instances of http my pages began to save again. I used Elementor to firstly change http and then used it to rebuild the css & that fixed everything.

    I had this issue with an AWS Lightsail instance running behind Cloudflare with SSL. The browser was talking HTTPS to Cloudflare which was talking HTTP to the backend.

    To fix, I had to un-proxy from Cloudflare, enable LetsEncrypt SSL on the instance, update wp-config.php to use https in WP_SITEURL and WP_HOME then set ‘Full SSL’ when proxying through Cloudflare.

    Now both the server and the browser concur about HTTPS being used.

    I had repeatedly “Publishing failed. You are probably offline.” while just adding new entries/media in a post. IF I add just 1-2 then no problem. IF I add many & only THEN want to preview or update then this problem comes. The preview website open also and just turns around endlessly without showing anything.

    I am an artist, I understand nothing about this.
    After I ahve read your posts I checked all my posts/pages. They all start with https.
    SO no idea. If this is a bug ( it is) then why wordpress does not repair the bug?!

    This is definitely a WordPress bug because I’m also having the same issue. I created the site some 4 days ago but now whenever I want to update a page I’m getting the error message that says “Updating Failed. You’re Probably Offline.” There must be an easy fix or something to address the issue. I’ve tried creating a new page and I’m getting the same message “Publishing failed. You’re probably offline.”

    They must fix it!

    Hello, I am very new here. I just created my page about three days ago. I have not been able to post anything since that day. I have read these posts and I did understand the HTTP. I have this correct. I do not know what else to do. I can’t post or edit anything.

    Same issue for a website I update for a friend. I can’t make any changes to pages whatsoever. It’s not a hosted site, and I can’t change the http to https. Do I need to get their FTP info and change it there? This isn’t cool.

    I couldn’t figure it out after many days of trying so I went to the Bluehost homepage and clicked to chat for help. The rep was very nice and was able to log into my page and look for the problem. She was able to fix whatever it was in just a few minutes. This is what I suggest doing. This was the only way I could fix it. 🙂

    changing the site address url from http to https fix this for me as well. my server is set to redirect to https but I also think this is related to gutenberg and the classic editor might not have this problem.

    Hello all,

    Just to let you know, I had the same issue and tried many things without finding a solution for a while.
    Here is the solution I found :
    This on top of updating the wp-config.php file, of course.

    I found a fix on this. On my case I configured wordpress on http then when I installed SSL (https) that is when I encountered this problem.

    Check my link

    Quick solution is changing the URL in your Settings.

    • This reply was modified 2 years, 7 months ago by hello_world. Reason: typo err

    @adelporte which one in the link?

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘Publishing failed. You are probably offline.’ is closed to new replies.