Support » Fixing WordPress » Publishing Failed

  • I’ve done some googling and found that the issue is with wp-json and REST API, problem is idk what these are or how to make sure they’re enabled

    Site is just hosted on my home server for fun, so I’m thinking maybe I have a config error somewhere. I installed the Classic Editor plugin and it at least allows me to “publish” the page, but then the new URL doens’t work, says “page not found”. So URL rewrites aren’t working? But I have the apache mod for it enabled. But maybe it’s something with .htaccess? I don’t know, I’m a layman here. I did install a security plug-in (Wordfence Security) that did something to .htaccess, but I tried disabling it and the issue still occurs. It did prompt me to download a backup of .htaccess first so I do have that if I need to restore it. As of now the plugin is still disabled.

    Ubuntu Server 18.04 running a LAMP stack if that matters, WordPress latest version 5.1.1

    Can someone tell me where to find this wp-json and REST API? Idk what these are, is it a package? A setting? A config file? idk

    • This topic was modified 3 months, 1 week ago by  abdulhakeem0.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator t-p

    (@t-p)

    tell me where to find this wp-json and REST API?

    https://wordpress.org/search/REST+API/#gsc.tab=0&gsc.q=REST%20API&gsc.sort=

    abdulhakeem0

    (@abdulhakeem0)

    Thanks but this doesn’t help me. I’m not a developer. I should just be able to install and use WordPress as a basic user.

    For me, this issue seems to be the browser.

    I normally use the Brave browser, but when I started getting the “Update Failed” and “Publishing Failed” error, I tried Firefox and I didn’t get these errors anymore.

    Also a possible solution (as the issue cropped up again in Firefox, later), is disable Cloudflare caching if your site uses that. Making this change may not be an instant fix either, as it requires DNS propagation to take place first. You may need to come back to WordPress the next day, for example.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.