Support » Fixing WordPress » Publishing fail after update to wordpress 5.0

  • Hello,
    After update to wordpress 5.0, I can’t publish any post at all. It keeps showing up Publishing failed error. Also, after save the draft. After that, I cant save it as draft/publish or anything. It only shows Draft failed, Publishing Failed. I only able to change it through quick edit.

    Further more, I can’t make any setting changes at all. Whenever I click save in the Setting menu (Permalink, etc) it gives me error HTTP 500

    • This topic was modified 1 month, 2 weeks ago by  ninhigan.
Viewing 15 replies - 1 through 15 (of 46 total)
  • i have the same problem!!!

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    If you have any type of “security” plugin, make sure that you have not set it to disable the “REST API”. If the plugin has a setting for that, turn off the setting. If that doesn’t work, turn off the security plugin.

    no security plugin is activated … doesnt work

    I also have the same problem. When i push “update” or “publish” absolutely nothing happens… and i disabled “All in one WP security”.
    Anyone else knows something?

    same problem here cannot update publish or save anything …

    We had blocked /wp-json on the server. Removing that solved the problem.

    rusty

    (@rustyshacklefordenator)

    I had the same problem. Tracked it down to as issue with a 404 relating to some wp-json stuff. After Googling the error the solution (for me, anyway) was to update Permalinks in WordPress (Settings -> Permalinks).

    I changed it to a different permalink structure and saved. Then I changed it back to the original structure I was using and it was still working. I may not have needed to change it and possibly just clicking ‘save’ in the first place would have been enough.

    If it’s a live website maybe just be careful with changing permalinks in case it messes things up.

    Edit: On another install I just went into Permalinks and clicked ‘save’ and it solved the problem. No need to change the permalink structure.

    • This reply was modified 1 month, 2 weeks ago by  rusty.
    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Yes, if you’re blocking wp-json and thus blocking the REST API, then the new editor will not work.

    The new editor is a javascript application. It runs in your browser, and communicates to your site using the wp-json REST API. You need to have that enabled. If you have added any security plugins, or anything similar to block that, then you will need to undo that in order for the editor to work properly.

    How do I enable the wp-json RESR API? I never disabled it as far as I know, neither did I have an activitaed security-plugin installed?
    Thanks

    A total disaster so far. As a development company we have over 100 websites running wordpress. A number of websites (5) got stuck in the database upgrade loop, we could not resolve this and rolled back to the previous version of wp.

    We also have 12 sites now that will not update or save pages, we have disabled all plugins and it has not resolved. The 404 in the console is:
    api-fetch.min.js:1 POST URL/wp-json/wp/v2/pages/4188/autosaves?_locale=user 404 (Not Found)

    The update has not created a wp-json dir, so obviously a 404 returns. We have also rolled these sites back.

    We have pulled the plug on 5.0 for now. It is not ready to launch. Our advice to anyone trying to upgrade on a live website is not to do so.

    We expected issues, hopefully in time they will be resolved.

    I can confirm rustys solution to reset permalinks does seem to have resolved this issue for us

    The reset of permalinks did not work for me.. I tried both to click save without anything else and also changed into a different structure, saved and changed back. Anyone else with more ideas?

    Same issue here

    /wp-json works fine
    Permalinks have been reset
    No plugins are enabled and Twenty Nineteen theme active

    Same problem here. Help!

    I’ve tried resetting the permalinks, disabling plugins, but would someone explain the /wp-json thing to me? How do I do whatever I need to do there?

    Thanks in advance

    Same here! Please Fix This!

Viewing 15 replies - 1 through 15 (of 46 total)
  • The topic ‘Publishing fail after update to wordpress 5.0’ is closed to new replies.