Support » Fixing WordPress » Publishing a post takes 2 to 5 minutes

  • Resolved MichaelH


    Completed an install4free request, but upon testing the installation, found it takes 2-5 minutes to Publish a post and return to the Write Post screen. Once it just returned to a blank screen after saving the post. If I interrupt the publishing process, the post seems as it was completely saved. Any ideas on what is happening or what I can look at?

    WordPress 2.0.7, default theme, no plugins
    PHP Version 4.4.4-pl4-gentoo
    MySQL 4.1.21

    Other things tried that didn’t solve the problem:

    1. Reuploaded WordPress files 3 times

    2. Tried setting Options, Writing, Update Services set to empty or three other different services

    3. Discussion, Allows Pings, on the Post checked or unchecked

    4. Tried Firefox and IE6

    5. Visually Rich Editor on or off

    6. Installed Pingfix plugin and that didn’t solve (

    Other information:
    7. Put php_value display_errors in .htaccess and it showed no errors

    8. Login was unbearably slow so solved that problem by disabling the feeds to the Dashboard by commenting out lines 18,129,146 in wp-admin/index.php.

    9. shows a yellow warning for “Glue at parent nameservers” but end-user doesn’t think that is a problem.

    10. Saving a post as a draft happens almost instantly.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The glue issue wouldn’t affect it. That’s you’re using nameservers with *.com tlds for a *.net domain for example. technacally that’s against the rules but pretty much ignored now a days.

    If the draft is being save instantly, I’m leaning towards outbound pings myself as the issue. The ping plugin that you link to wouldn’t affect it since all it does it appears is not resend pings. The pings still go out when you publish. That plugin just doesn;t try resending them if you’ve published the post in the past.

    There’s a different ping plugin but I can’t find it right off. It sends pings out later on when it has time instead of all at once.

    A forum user reported, via email, that he experienced the same problem I reported above with nedlinux.

    In his email, he told me he reported the problem (slow posting) to the nedlinux support department, they acknowledged they had previously heard the problem, and suggested a move to a different server to solve the problem.

    And so, he emailed me today saying that the move to a new server did in fact, solve the problem.

    Marking as resolved.

    Here’s some extra info:
    <brag> and probably a real solution </brag>:
    it turns out, that function spawn_cron() in cron.php takes a timeout of 5 minutes, at least at Nedlinux. My website is hosted at Nedlinux and I’m quite happy with them, but this is an undesired effect.

    As a solution, which works for me, I patched cron.php, line 87:
    – $argyle = @ fsockopen( $parts[‘host’], $_SERVER[‘SERVER_PORT’], $errno, $errstr, 0.01 );
    + $argyle = @ fsockopen( $parts[‘scheme’].’://’.$parts[‘host’], $_SERVER[‘SERVER_PORT’], $errno, $errstr, 0.01 );

    The original call tried to open, the patched version tries to open

    …and now I can finally start blogging… 🙂

    JohnnyD, you’re a marvel! Thanks a million, since moving to another hosting wasn’t an option for me

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Publishing a post takes 2 to 5 minutes’ is closed to new replies.