WordPress.org

Forums

Published Pages Not Showing Up on Blog (16 posts)

  1. ted_smith
    Member
    Posted 6 years ago #

    Hi

    Just installed latest version of WordPress on my server (IIS7, Windows Server 2008, PHP5). Installed fine. However, when I create new 'Pages', none of them are showing even though the widget sidebar is activated. Also, the number of published pages is shown in 'Pages Admin' section but you cannot see the pages themself. It just says "No pages found.". None of them show on the blog itself.

    I have searched this site and found several posts relating to this same problem spanning several months, so I would have thought it would be fixed by now? The links to these threads are :

    http://wordpress.org/support/topic/188877
    http://wordpress.org/support/topic/203306
    http://wordpress.org/support/topic/187871
    http://wordpress.org/support/topic/156518

    and several others. None of them document a solution - just lots of other people saying "I have the same problem..."

    So can anyone suggest a way to fix?

    Thanks a lot

    Ted

  2. MichaelH
    Member
    Posted 6 years ago #

    The wp_posts table should show those pages as 'post_status=publish' and 'post_type=page'.

    Have you tried updating your permalink structure.

  3. ted_smith
    Member
    Posted 6 years ago #

    According to the database, the post_status is 'publish' and 'post_type=page'. However, directly beneath it, the entry appears duplicated but it says post_status is 'inherit' and 'post_type=revision'? Not sure if that means anything?

    Have you tried updating your permalink structure.

    When you say 'updating it', what do you mean exactly? Do you mean changing it from the default value to one of the others, or is there code to update it?

    Lastly, when I 'Add' the 'Pages' Widget, my entire right hand sidebar goes blank? All my other sections are removed. When I remove the Pages widget, they come back again. Most odd.

    Ted

  4. MichaelH
    Member
    Posted 6 years ago #

    Yes wp_posts will have revisions so that seems okay.

    As for the permalinks, just visit Administration > Settings > Permalinks and Save Changes.

    Deactivate all plugins and change to the WordPress Default theme.

  5. ted_smith
    Member
    Posted 6 years ago #

    Nope - no joy.

    As for the permalinks, just visit Administration > Settings > Permalinks and Save Changes

    - done that. No change.

    Deactivate all plugins and change to the WordPress Default theme.

    Didn't have any activated anyway and was using the default theme.

    But still shows the same, and when I activate the Pages widget I lose my right hand side bar.

    This is very irritating. :-(

    If there's anyone expert enough to login and have a look, if you PM me I will give you the details.

  6. MichaelH
    Member
    Posted 6 years ago #

    Please consider posting a "New Job Request" [1] to have a professional work with you, or consider joining and soliciting professional assistance from the wp-pro mailing list [2].

    [1] http://jobs.wordpress.net/postajob.php
    [2] http://lists.automattic.com/mailman/listinfo/wp-pro

  7. Brycestro
    Member
    Posted 6 years ago #

    Try changing your permalinks structure back to the default structure and see if the pages work.

    I've just installed 2.7 and had a similar problem where none of my pages would show up in my browser even when i typed in the link manually. After some testing I found it occured when updating the permalink structure and went again after reverting it.

    Not really a long term solution, but would be interesting to know if others are experiencing this same issue.

  8. Brycestro
    Member
    Posted 6 years ago #

    Ok, looks like my problem was that the Wamp testing server I was running on my local machine didn't have the Apache rewrite_module enabled. Once I enabled that I could use the longer permalink format fine. Any chance this is the issue you're experiencing?

  9. technopatra
    Member
    Posted 6 years ago #

    I had the same problem, and changing back to the default permalinks and changed my Unix permissions for those folders from 755 to 777 seemed to work.

    But does anyone know how I can get the permalinks I want? When I made the changed, I got a message that said I should go 'update the .htaccess file" but I have no idea what that is, or where I could get it. I did a search for .htaccess and went ahead and changed the permissions of the folders for the 4 files that referenced it, but no luck.

    Can any of you gorgeous, brilliant people tell me explicitly how to update .htaccess?

  10. jobmatchbox
    Member
    Posted 6 years ago #

    MichaelH as a Moderator, is it really helpful for you to tell someone who is clearly having an issue with a buggy new version of WP to hire someone to help? Ted isn't the only person having this problem. Maybe you could contribute a solution. Earn your stripes.

  11. chodorowicz
    Member
    Posted 5 years ago #

    I have the same issue with newest WordPress 2.8.4 - and it's clearly due to some bugs in permalinks engine

    I had pretty permalinks turned on - everything working fine. Then after adding a page with a more complicated title (slashes and hyphens inside) it all broke down and only the default permalink structure works

  12. chodorowicz
    Member
    Posted 5 years ago #

    ok, clearly htaccess was corrupted in some way (by a plugin?)
    it looks like this now
    http://www.copypastecode.com/11370/

    but still, even after 'repairing' it, the problem persists, pages are still not displayed

  13. chodorowicz
    Member
    Posted 5 years ago #

    ok, my problem is kind of solved - it was all fault a custom function in functions.php - it corrupted the database - but anyway it's strange because it works tip-top on a remote server, but locally on WAMP server it fails in such a way

  14. Change09
    Member
    Posted 5 years ago #

    I launched a new site on Friday and everything was fine. Today there is a page missing from the menu even though it's all there in the page list and admin area. I've tried changing permalinks as suggested in a previous post but no joy. Have tried removing the page and re-installing but nothing. I have no custom programming of any kind as I wouldn't know how. Can anyone else suggest anything else to try to rectify this? I'm using WordPress 2.8.4. Any help would be appreciated.

  15. Change09
    Member
    Posted 5 years ago #

    Have removed the page and started again and it seems to be there now. Not sure what all that was about but it seems sorted.

  16. kristiwright
    Member
    Posted 5 years ago #

    This is also a problem for me w/ wp version 2.8.6. I tried resetting permalinks to the default but that did not correct the problem.

    Any help out there?

Topic Closed

This topic has been closed to new replies.

About this Topic