Support » Fixing WordPress » Published Pages Displaying 404 Or Worse

  • Hi everyone,

    I’m having an issue with a WordPress site that I’m in the process of developing. I’ve built a number of WordPress sites before, and never encountered this.

    For some reason the navigation links are being a bit temperamental, and most of the time clicking on one of them leads me to a 404 page. These pages are definitely published, and the navigation is being pulled dynamically from WordPress (instead of me creating an unordered list in my header file). I did a bit of Googleing found that others had experienced a similar issue, and the recommendation was to reset the permalink settings. Whilst that has seemed to work for most people, it works for me briefly and then appears to revert back to the error the next time I go to work on the site.

    Any thoughts?



Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi,

    I’ve got a parse error right now, are you actually working on it ?


    I’m logged in to the WordPress back end, but not doing any work. 🙁


    When I can’t reach the about page : because of this error, apart from that post permalinks seems to work well.

    Did you check the HTAcces file via FTP ? leading to a 404 page might be a result of a bad .htaccess configuration.

    A standard htaccess looks like this :

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    2 lines are important and might lead to a 404, in your case you should have : “RewriteBase /” and “RewriteRule . /index.php [L]”

    Another point, is mod_rewrite.c activated ?

    Hi jeFFF

    I’m using Coda to write my theme, and I can’t see the htaccess file anywhere in the file list there. I can see it when I log in to my cPanel, and it reads exactly as you’ve said it should.

    I’m not quite clear on the mod_rewrite.c part, however.

    It it’s activated, you should see it with a phpinfo page.
    Search for the “mod_rewrite” string on the page it should be in the “apache2handler” section under “Loaded Modules”.

    As you can use post permalinks without problem, I guess it’s activated already.

    Well, try something that saved me sometimes (especially in a migration process). If you didn’t do that yet, you go to the Permalinks settings, cut the custom string activate the default value and save the page. When the page is saved, paste the custom string again and save again.

    This trick will regenerate the .htaccess and the permalink structure, maybe it will correct your issue.

    But first, get rid of that ugly parse error in the 404 page 😉

    I’ve tried that a couple of times, and it works for a little while and then reverts back to this issue again. As it’s a new site, I’m thinking I might just save my theme and trash the install. Shouldn’t take me too long to redo, and then I can just install my theme again. 🙁

    Thanks for your help Jeff.



    You’re welcome Chris 😉


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Published Pages Displaying 404 Or Worse’ is closed to new replies.