'Publish' is terribly slow and returns blank page (4 posts)

  1. stevejohnson
    Posted 9 years ago #

    Forgive me if this has been posted somewhere; if it has, I can't find it.

    This issue came up after upgrading to 2.0.3 from 2.0.2.

    When I 'publish' a post, WP takes forever to redisplay the dashboard, if it does at all. Several times, I've had a blank page returned from wp_admin/post.php (I haven't looked at the page source to see if anything is really there or not, but it's still not right).

    The post is actually published (it will show on a screen refresh in another window).

    This behavior does not occur with 'save and continue' or 'save' buttons, only with 'publish'. Any ideas?

    EDIT: I have tried deleting the cache folder and forcing a refresh. Also, this behavior doesn't happen when publishing a 'page', only a 'post'.

    When posting a test post, I clicked the publish button, and got the standard 'waiting for ...' in the status bar, and the page shows as loading, but the screen doesn't change. IOW, the post editor is still showing, with all the content.

    If I scroll to the top of the screen and click the 'view site' link, the site immediately loads and the post is displayed.

    So the problem is occuring after the database writes.

  2. Chris_K
    Posted 9 years ago #

    Logged in as Admin, go to Options -> Writing. What all do you have listed in "Update Services"? Sounds like one of them is not responding (traditionally that would be the pingomatic service).

  3. stevejohnson
    Posted 9 years ago #

    Oh, my. I didn't even think of that.

    Thanks, I'll take a look.

  4. stevejohnson
    Posted 9 years ago #

    Thanks, Handy. That was the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic