Magic Fields 2
[resolved] Publish (custom) posts vs. WordPress 3.9 (5 posts)

  1. 0bservator
    Posted 1 year ago #

    Since the update to WordPress 3.9, Magic Fields 2 causes a warning when publishing a new post. When I click the Publish button, my browser (tested with Chrome and Firefox) askes me if I want to leave this page. When you click 'I want to stay at this page', nothing happens. When you click 'I want to leave this page' you don't actually leave the page; the post just gets published as you expect it to do.

    I disabled all my plugins to test which one causes the problem. It appeared to be Magic Fields 2. I downgraded WordPress to 3.8.x and the problem was also solved.


  2. S3nd41
    Posted 1 year ago #

    Do you still get the TinyMCE editor on multiline fields? Mine has disappeared after updating to 3.9.

  3. Dave Navarro, Jr.
    Posted 1 year ago #

    Something is screwed up in 3.9. Several plugins cause this in 3.9 (including TinyMCE Advanced, Smart Fields, East Content Types).

    It does not happen in 3.8.3, so something changed in 3.9 that broke a bunch of plugins.

  4. 0bservator
    Posted 1 year ago #

    Since the last updates (both WordPress and Magic Fields) this problem seems resolved.

  5. S3nd41
    Posted 1 year ago #

    Interestingly enough I downgraded one of my websites in order to get Magic Fields working but now, by mistake, I automatically upgraded both WordPress and MF and it continued to work.

    So I decided to update them both on another website and, alas, it's still bugged. Maybe there's another plug-in causing the conflict or it's just something related to the different post structure, I don't know.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Magic Fields 2
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic