Support » Plugin: Jetpack by WordPress.com » Publish button not working since upgrade to 2.9

  • Resolved plymouthunitedorg

    (@plymouthunitedorg)


    Updated to 2.9 today, and went to publish a post. Can save drafts, but when I hit publish, the post “refreshes” as it normally does when doing spellcheck and then freezes.

    I deactivated Jetpack, went to the draft post, and all text was missing. Previous revisions were all available. I was able to restore from a previous revision and publish the post (without Jetpack) with no further issues.

    https://wordpress.org/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Do you have the same problem when trying to publish both posts and pages?

    esmi

    (@esmi)

    Forum Moderator

    @cnhub: It is considered impolite to interrupt another poster’s ongoing thread unless you are posting a solution or suggestion. As per the Forum Welcome, please post your own topic.

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Happiness Engineer

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

    Make sure to include a link to this thread in your message.

    Certainly. It’s plymouthunited.org

    I am experiencing this same issue. It’s caused by a TypeError originating in modules/after-the-deadline/atd-nonvis-editor-plugin.js at line 138:


    TypeError: window.wp.autosave.local.suspend is not a function

    Disabling automatic proofreading in the User Profile options fixes the problem for me.

    Plugin Contributor Brandon Kraft

    (@kraftbj)

    Happiness Engineer

    Howdy y’all,

    We’re working on tracking this down now. I was able to duplicate in the following conditions:

    • Publishing or Updating a post
    • In Firefox (latest on OS X, in my case)
    • When using the “Text Editor” within WordPress. The visual editor is not impacted through my tests
    • Your user profile is set to automatically proofread on publish/update

    If any of the above is *different*, please note it here and I’ll either include it in our testing or ask you to post a new thread if it is seemingly a different issue.

    Cheers!

    All is the same on my end, except that I am using Safari (7.0.1), also on OS X.

    Thanks!

    Plugin Contributor Brandon Kraft

    (@kraftbj)

    Happiness Engineer

    Howdy again,

    My apologies for the delay and the trouble with version 2.9. We are uploading version 2.9.1 to the servers now, so you should see an update notice in your WordPress dashboard relatively soon.

    Everything seems to be working just fine now since updating to 2.9.1! Thank you so much for your help!

    The update did not fix the problem for me. When editing a recent post it wouldn’t even save my changes until I deactivated Jetpack.

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Happiness Engineer

    Hi Zazen,

    Can you confirm what WordPress and Jetpack versions you are using? Could I have your site’s URL so I can have a look?

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Happiness Engineer

    Hi Zazen,

    I notice you are running Bad Behaviour. Just out of curiosity, could you disable that plugin and any others you may be running, to see if there’s a conflict somewhere? If you are able to save your changes with just Jetpack active, then try activating your other plugins one by one until you find a conflict. Let me know if you turn up anything.

    Deactivating the plugins I use, then reactivating them with Jetpack running – well I couldn’t find any problems today. I have no idea why it wasn’t working Saturday but the problem seems resolved today.

    Thanks for your help.

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Happiness Engineer

    Glad to hear it, Zazen. If anything else odd happens, let me know!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Publish button not working since upgrade to 2.9’ is closed to new replies.