Support » Fixing WordPress » Publish (and draft) date and time wrong

  • Resolved Hansaplastique

    (@hansaplastique)


    I’m using WordPress 3.2.1 on my own server (CentOS 6 64bit, PHP 5.2.17).

    Link to my website: http://www.tweaking4all.com (I manually corrected date and time in the admin pages so they would show up correctly)

    When saving a post as a draft, it saves it with the wrong date (Jan 25 instead of July 26 – year is correct) and wrong time (always 0:00). Obviously when publishing a post the date and time is equally wrong, which I tend have to correct manually after posting (since I can’t edit the date/time of a draft).

    – Server date/time is correct it seems: Tue Jul 26 22:45:47 EDT 2011

    – Time settings in admin page (Tools>General) is set to Chicago, showing
    “UTC time is 2011-07-27 2:45:53”
    “Local time is 2011-07-26 21:45:53” (daylight saving)

    – Examples (for Date format) in the admin page display correct as well (July 26, 2011, 9:45PM)

    I hope someone can help me – I must be overlooking something very simple.

Viewing 15 replies - 1 through 15 (of 17 total)
  • After 6 days; I have made zero progress.
    Looked at severe date/time related posts in this forum and searched Google.
    Seems I’m the only one with this issue?

    Help would be very much appreciated. 🙁

    @hansaplastique,

    It would appear you’re not the only one with this problem 🙁

    All my new posts are backdated by 8 eight months (specifically Jan 30, 2011). And the time is set to 00.00

    I’ve double checked my time settings and all looks good. The timing is supposed to be automatic, isn’t it?

    Help please! What can be done?

    Sounds like we have exactly the same problem!
    (it is a little bit of a relieve to hear that I’m not alone)

    I unfortunately have not found a solution to it either.

    I’ve considered adding a trigger to the database to automatically set the date/time to NOW() on insert of a new record.
    Which I really don’t like doing since WP should set a date/time automatically.

    I double checked all settings, date/time on the server, etc etc.
    Can’t find anything wrong either 🙁

    Maybe we have to post a bug report (not sure where and how though).

    yeah, We may need to post a bug report. I’ll try and look around to find out how.

    But do you know what files are responsible for the date/time function? I think replacing the file(s) could do the trick. I noticed mine was working well until about a month ago. Some old posts I made where correctly dated. Only the ones I made recently have the dating problem.

    What do you think?

    Mine worked just fine until I updated to (if I recall correctly) 3.2.1.

    I’m not sure what file has the date/time function, but it would be good to figure that one out. I’ll try tonight and see what I can come up with.
    This way we can add a change suggestion with the bug report.

    The initial idea I had would be a trigger on the database, so independent of the WP code.

    I sure wish some experienced WP users could help out 🙂

    Please let me know what you come up with.

    I’m not sure why no one has responded to this thread 🙁

    @hansaplastique,

    Any luck with finding the file(s) responsible for date and time?

    Have you been able to find a way around this problem or submit a bug report?

    esmi

    (@esmi)

    Forum Moderator

    @levelsevenltd: Please post a new topic.

    [EDITED]

    Sorry guys – haven’t had time this week to look into this topic (remodeling home).

    @esmi; what do you mean with please post a new topic?

    esmi

    (@esmi)

    Forum Moderator

    Sorry – my comment was directed at levelsevenltd. I should have made that clearer.

    esmi

    (@esmi)

    Forum Moderator

    @hansaplastique: WordPress picks up the date/time from the server. So you need to look at your server’s timestamp.

    No problem 😉

    Just wanted to make sure I understood what you were asking 🙂

    The date time is set correctly on my server.
    It almost looks like it’s trying to “swap” day and month.

    esmi

    (@esmi)

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Yes I did … 🙁

    Based on your suggestion I disabled ALL plugins from the admin pages again. And re-activated them one at time. And behold: it fixed the date issue!! Woohoo!

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Publish (and draft) date and time wrong’ is closed to new replies.