Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Publicizing doesn’t take from og:image meta

  • Resolved Rasetsukoku

    (@rasetsukoku)


    Hi, I’m trying to force Twitter & Tumblr to use a specific image.

    I filtered jetpack_open_graph_tags with a custom function that sets the og:image to my own image. This works fine. When checking the source of my post, the meta is set to the one I intended. It also works on Facebook.

    However, when posting to Tumblr & Twitter, it STILL uses my featured image instead of the og:image meta.

    1. a) I’ve attempted to set the default image to this picture, even if there is $media. It is still my featured image.
    2. b) I’ve attempted to set the og:image:width and og:image:height to my intended image’s width/height, however it seems to be pretty random that jetpack actually adds width/height, and if it does add width/height it’s still the same as my featured image and I don’t know how to change it. I tried using the same unset method as I used to change the og:image, but it didn’t work.
    3. c) As for Facebook, the intended image displays when being publicized, even when og:image:width and og:image:height are of the featured image’s dimensions.

    EDIT: I found that twitter is using the featured image because of the twitter:image tag; again I am unsure of how to change/override this as the same technique with og:image doens’t work.

    • This topic was modified 4 years, 11 months ago by Rasetsukoku.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter Rasetsukoku

    (@rasetsukoku)

    I can’t seem to edit my post after the first edit, but I’m still having issues. This post is technically considered my second edit.

    I did manage to change twitter:image, and I also disabled Jetpack’s twitter cards and just put the information myself in the same filter that changes og:image. I also managed to get the width and height working correctly now.

    og:image and twitter:image have both been successfully changed to the image I wanted, and this displays in the source. However, when publicizing to twitter, it STILL is my featured image.

    I’m at a loss now. 🙁

    Hi @rasetsukoku – Did you make the changes to your twitter meta data after the post was published? If so then Twitter may have already cached, you could try following Twitter’s guide below on refreshing the card:

    https://dev.twitter.com/cards/troubleshooting#refreshing

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Publicizing doesn’t take from og:image meta’ is closed to new replies.