Support » Plugin: Jetpack by WordPress.com » Publicize Will Not Connect

  • Resolved DanGarion

    (@dangarion)


    Hello,

    My Jetpack will connect back to Facebook or any other Social Media in the publicize section.

    I have already verified that my http://dangarion.com/xmlrpc.php appears to be working.

    And I’m getting the 500 status code for “POST /sites/1695471/publicize-connections/new” error on Sharing section.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic ๐Ÿš€

    While the XML-RPC file can be accessed in your browser, we can’t actually make any requests to it; we are blocked by a security plugin or by your host. Here is the message we receive:

    
    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>403 Forbidden</title>
    </head><body>
    <h1>Forbidden</h1>
    <p>You don't have permission to access /xmlrpc.php
    on this server.<br />
    </p>
    <hr>
    <address>Apache/2.4.25 (Debian) Server at dangarion.com Port 443</address>
    </body></html>
    

    Could you ask your hosting provider to take a look at this and make sure one can make POST requests to /xmlrpc.php on your site?

    I hope this helps.

    This is strange. I have verified permissions for that file and it is the same as all the other WP files 644 www-data.

    I will look through my error logs and try to figure out what is going on. I disabled my cache and a security app to test as well but it still seems to not connect. ๐Ÿ™

    For those that have a similar problem that are running their own web server and using modsecurity you will need to whitelist the Jetpack IP addresses if you want to run modsecurity and use Jetpack.

    Your syntax in the modsecurity.conf will be something similar to this.

    SecRule REMOTE_ADDR "@ipMatch 122.248.245.244,54.217.201.243,54.232.116.4,192.0.64.0/18" \
      "id:'000001', \
      phase:1, \
      t:none, \
      ctl:ruleEngine=Off, \
      nolog, \
      pass"
    

    I received the IPs from Jetpack support.

    Recently I moved to a new host, so I’ll have to take it up with the admin.

    I thought and then I found a WordPress XML-RPC Validation Service that showed me that XML-RPC is perfectly reachable, but only through https.

    Can we confirm that Jetpack uses http or the www prefix?

    • This reply was modified 2 years, 3 months ago by Blamedutchie. Reason: ongoing trouble shooting
    • This reply was modified 2 years, 3 months ago by Blamedutchie. Reason: ongoing trouble shooting
    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic ๐Ÿš€

    Can we confirm that Jetpack uses http or the www prefix?

    Jetpack will use what your site is set to use, under Settings > General in your dashboard. If your WordPress address is set to use HTTPS we will use that!

    Ok, thank you for the reply, Jeremy!

    Does not explain what went wrong, but we fixed a a certificate issue that popped up after moving the site to a new location. Should not be connected to this error, but apparently it did.

    For some reason I did not receive an email about your reply, even though the `Notify me of…ยด selection box is selected.

    Cheers!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Publicize Will Not Connect’ is closed to new replies.