Support » Plugin: Twitter Cards Meta - Best Twitter Card Plugin for WordPress » Publicize to twitter not showing images in twitter feed

  • Resolved PegWeb

    (@pegweb)


    I installed the plugin and it validates using twitters card validator. However when I make a new post to the blog and using JetPacks Publicize it posts that to Facebook and Twitter the image does not show up in the twitter feed. It only is visible if you click the View Summary link on the twitter feed wall. How can I get the image to show up in the twitter feed on the wall without the user having to click the View Summary link? Example.
    https://twitter.com/CrossFitAArena

    https://wordpress.org/plugins/twitter-cards-meta/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author M Asif Rahman

    (@asif2bd)

    If you share as link, it will show up like this in your Twitter Profile, but thats how Twitter designed their site. But your Twitter Card will show up perfectly in search, or others timeline.
    Look at this example search result – https://twitter.com/search?q=Prepare%20for%20the%20last%20Open%20Workout%20this%20year!&src=typd

    And I do see you still using Yoast SEO’s Twitter Card option, you have to turn Twitter Card function from SEO => Social Setting to use this plugin.

    And if you pin one tweet in your profile, that will show with card.

    So there is no way to use Publicize to post to the Twitter wall with an image?

    Plugin Author M Asif Rahman

    (@asif2bd)

    It actually does not make sense, as you are doing what Twitter permits, means no others doing anything extra.

    Personally whenever I have an Eye-catching grafix for a post, I share it as image, instead of link, and you could do the share manually or using any other service, just not automatically via jetpack. share as image, write one line text and copy paste the url of the post in the tweet.

    When you say share it as an image can you explain in more detail what you mean? Not sure I understand what you are saying here.

    Plugin Author M Asif Rahman

    (@asif2bd)

    Here is an example tweet I just did – https://twitter.com/Asif2BD/status/713094838930026496

    Yeah that is exactly what we want it to do. The question is there anyway to get it to automatically appear on our Twitter feed like that when we make a Post on our WordPress site. It looks like all Publizice from JetPack does it send the link to the article to Twitter.

    Plugin Author M Asif Rahman

    (@asif2bd)

    Actually you could. It’s not too too complex, just have to configure to share as image, and grab image from post automatically. I do it automatically where I need. But thats beyond this plugin capacity, and you better contact us in our support or email info at wpdeveloper.net

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Publicize to twitter not showing images in twitter feed’ is closed to new replies.