Support » Plugin: Jetpack by WordPress.com » Publicize to Facebook Not Working?

  • Resolved purepooetry

    (@purepooetry)


    Suddenly Publicize to Facebook is not working for me. Twitter is fine, but not Facebook. I’ve noticed this from the last two posts I’ve made to my website (Monday and today, Wednesday). I’ve had to manually post them to Facebook. My next post will be on Friday.

    I’ve disconnected the Facebook account in Jetpack > Settings > Sharing, and reconnected, and yes, ticked the box “connection available to all admin, auths and editors.”

    The only thing I can think of is on the weekend I connected a different Fb Page up to a different WordPess / Jetpack website I have. But that shouldn’t affect the one I’m talking about? I did the reconnection AFTER this weekend so things should be back to working IF this different account is clashing.

    https://purepooetry.com
    https://www.facebook.com/purepooetryonline/

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Our tests on this end seem to think that your site cannot communicate with our services, but I also can’t find any obvious blockers.

    I suspect something incorrect may be lodged in the plugin settings.

    Please try deleting Jetpack specifically from the Plugins section of your blog’s Dashboard.

    This will clear out Jetpack’s settings, and it should work properly after a reinstall.

    Thanks James. Just deactivated, then deleted. Had a hiccup installing 7.2… It failed, tried again, and it was fine. Then activated it. I’ll attempt a Publicize Post on Friday and report back. 🙂

    Plugin Support Gemma Evans

    (@gemmaevans)

    Hi @purepooetry,

    I’ll attempt a Publicize Post on Friday and report back. 🙂

    Thanks — we’ll keep our fingers crossed but do let us know if the issue is still there and we can take another look.

    Ok, Friday’s post worked.
    I just did another now and it did not work. I should point out that the one I did just now was in draft status since yesterday (Friday), and now it is Saturday. I don’t know if that has anything to do with it, but I have had issues with that were left in draft status for a day or few, and then posting.

    Edit: Today’s post didn’t work for Facebook or Twitter. Yet, I got the notification in WordPress to say it was sent. :S

    • This reply was modified 6 months, 2 weeks ago by  purepooetry.

    I should let you know, the posts did finally arrive. It took a few hours to show up though. Very odd.

    Plugin Support darnelldibbles

    (@darnelldibbles)

    Glad to hear that it arrived. Let us know if you continue to get these posts delays and we’ll continue to look into this.

    Thanks!

    I did a post yesterday, and it was instant. So maybe I just had some odd hiccup… Thanks for the help!

    purepooetry

    (@purepooetry)

    Hi again.

    I just had another instance of this not working for me. This time I was using Post By Email. The entire post has not shown up yet (on socials and my website).

    I checked all my settings, and every thing is set to work, so I dunno what is going on.
    🙁

    I’m reluctant to bother using Post By Email again now. I don’t know if this post will eventually “turn up” in a couple hours, or not. So do I bother manually posting, or wait for potentially nothing? Is there a way to check somehow?

    • This reply was modified 6 months ago by  purepooetry.
    • This reply was modified 6 months ago by  purepooetry.
    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    We’ll need to take a closer look on that, would you please contact us via https://jetpack.com/contact-support/?rel=support ?

    Hello
    I try publicizing my post to facebook is not working but twitter is working fine when I run a sharing debugger on facebook it shows fb app ID missing please how can I fix it.
    https://nkume.com

    Plugin Support Gemma Evans

    (@gemmaevans)

    Hi @nkume,

    We have already replied to you in this thread:

    https://wordpress.org/support/topic/jetpack-missing-fb-id/

    Please continue replying there if you still need help 🙂

    Hmm, I posted here yesterday, but it seems that my comment disappeared…
    Reposting, I guess…

    I just wanted to chime in that I am having the same issue. I have not changed anything (other than making a new post) on my blog or facebook page in months, but just recently, the Facebook option isn’t working. This happened for 2 websites, actually.

    http://backpackingandbeer.com/
    https://www.facebook.com/backpackingandbeer/
    The China post was just recently manually posted by me, but it did go to Twitter automatically.

    http://bridgersmusings.com/a-change-undisclosed/
    https://www.facebook.com/BridgerZCummings/
    “A Change Undisclosed” also had to be manually posted on Facebook.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    As that could be an entirely different issue or cause, please either open your own thread https://wordpress.org/support/plugin/jetpack/ or contact us via https://jetpack.com/contact-support/?rel=support

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Publicize to Facebook Not Working?’ is closed to new replies.