Support » Plugins and Hacks » Jetpack by WordPress.com » Publicize not working for scheduled posts

Publicize not working for scheduled posts

  • Publicize is working fine for direct publish posts but fails on scheduled posts.

    Tried twice. I currently have to manually post these to each social media outlet. A big problem since I shut off my normal auto sharing routes and most of my posts are scheduled.

    Is there a way to repost to initiate publicize until this is fixed?


Viewing 15 replies - 16 through 30 (of 32 total)
  • i have the same problem and now switched to manual task .

    Sheri to answer your question: I am not using the email subscription service.

    I’ll do some more testing this week to see if I can find a pattern in the posts that don’t publicize.

    Ooh question: are posts scheduled *before* the Publicize function is added NOT be publicized?

    Just to follow up on my original post: Posts are not being publicized to Twitter or Facebook for me whether the post is scheduled or published directly.

    Testing this out some more this week to see what’s working/not working. Both these sites are on the same server and are running off the same WPMU install.

    Testing on: offbeathome.com
    Author: me
    Scheduled post: yes
    Set to publicize to:
    Facebook: Offbeat Home
    Twitter: @offbeathome
    Tumblr: Offbeat Empire
    Where it appeared: on none of the sites

    Testing on: offbeatempire.com
    Author: me
    Scheduled post: no, published live
    Set to publicize to:
    Facebook: Offbeat Empire
    Twitter: @offbeatempire
    Tumblr: Offbeat Empire
    Where it appeared:
    Tumblr: Offbeat Empire

    One thing I’m noticing that confuses me:
    On Empire post: http://goo.gl/LizgX
    On Home post: http://goo.gl/mN29U

    We have the same problem.
    Our is setup to only post to Facebook and sometimes it does and sometimes it does not.
    I am sorry that I cannot provide more information at this time.

    Plugin Contributor designsimply


    Ooh question: are posts scheduled *before* the Publicize function is added NOT be publicized?

    I don’t think that should matter, but the post does have to be brand new and not have been published in the past.

    One thing I’m noticing that confuses me:
    On Empire post: http://goo.gl/LizgX
    On Home post: http://goo.gl/mN29U

    Those are supposed to become disabled after the post is published for the first time. A post should only ever be sent via publicize onceā€”the first time it is published.

    @arielmeadow, so based on what you’ve written above, you’re trouble is not just with scheduled posts? The best advice I can give so far based on the info provided is to try to disconnect and reconnect the publicize various connections and try again.

    Update: I disconnected and reconnected my site’s Twitter account from Publicize, but when I reconnected, I enabled the option to “allow all authors access to this account” within Publicize. After enabling this feature, Twitter Publicize worked for the first time.

    I’ll try with Facebook next, although I hate having to enable a setting like that to make it work.

    We are experiencing the same problem. If you need data for debugging, please let us know.

    I’m glad to know that I am not the only one with this problem. I have mine configured to send to Facebook and Twitter. When I tested manual posts there were no problems. I had a scheduled post work once, but fail the rest of the time.

    To answer an earlier questions, the subscription email seems to work just fine.


    I’m having the same problem here. Hit or miss posting behaviour.

    On my Publicize I have connected a Facebook and Twitter account, not without any trouble, had to retry several times for my social accounts to get connected.

    Once they were connected, made a test post that was posted on both social sites with success. After that, made something like 15 posts with Publicize enabled, directly published and only 4 were published on Facebook and Twitter.

    So has idoubtit said this is VERY hit or miss. Sometimes it work, sometimes it fails completely.

    Could someone point to plugins alternatives for automate posting to social sites, mainly Facebook and Twitter?


    We did not find a solution to this problem.
    But we did find a fix for those in need of a way to post to Facebook, Twitter and Linkedin.
    We switched to twitterfeed.com and use their service to publish our feed.
    While this does not fix the solution for Publicize. It did solve our dilemma and so far has been working great for the past month or so.
    I just thought I would share if anyone is in need of an alternative.

    I seemed to have fixed the problem. I was having issues with usage with my host company. I changed cache programs (went from W3 Total cache to Quick cache and I deleted my feedburner feed (was not using that). For some reason, this fixed the issue and my site runs better and the publicize feature works.

    I still do not use the facebook publicize feature because of the gravatar issue. I use IFTTT for that. You can easily create recipes that post where ever you wish.

    Just to give another alternative, I have just finished configuring NextScripts: Social Networks Auto-Poster plugin.

    It’s working flawlessly for my facebook and twitter accounts. It supports many other social sites for autopost.

    It has a very useful feature, an actions log where you can see if the actions succeded or failed. It also support manual reposting from the Edit Post in case the autopost fails or want a manual repost of and old one.

    Deactivated Publicize.
    Hope it helps!

    Kinda surprised this wasn’t addressed on the last Jetpack update. My site tends to run slow, so I don’t like to keep adding plugins (I have too many already), but I can’t be there every day to post content on FB and Twitter. So, thanks soflaweb and fackass, I’m going to try your suggestions.

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘Publicize not working for scheduled posts’ is closed to new replies.
Skip to toolbar