Support » Plugin: Jetpack by WordPress.com » Publicize no longer working

  • Resolved chiefgyk

    (@chiefgyk)


    Jetpack’s publicize feature has stopped working on my team’s site a few days ago for all social media we were connected to. Facebook, Twitter, and Tumblr all have not been posting as they should for the past three days. I have tried disconnecting and reconnecting the social media platforms, and jetpack itself but nothing is working as of three days ago. We installed a new theme but that was a couple weeks ago, and we haven’t installed any new plugins since the theme migration. Any help would be appreciated

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Cena

    (@cena)

    Hi there,

    Have you recently updated your site to use an SSL certificate? (http://beinglibertarian.com redirects to https://beinglibertarian.com ).

    I ask because the error I see on the Facebook debugger (for example: https://developers.facebook.com/tools/debug/og/object?q=http://beinglibertarian.com/bureaucrats-washington-fear-congressional-budget-act/) indicates there may be a conflict between the https and http versions of your pages. Have you updated your WordPress and Home URLs in WP Admin->Settings to reflect https?

    Best,
    Cena

    No we’ve been using an SSL since we self-hosted and using letsencrypt.org behind our cloudflare

    Forgot to mention we use HTTPS redirection on both the Nginx server and cloudflare to enforce SSL

    Plugin Support pmciano

    (@pmciano)

    We suggest contacting your host and explaining that we are unable to access your blog via cURL, which is needed in order to use Jetpack on your site.

    You can pass this information onto them:

    1. We checked for access to xmlrpc.php via browser:

    https://beinglibertarian.com/xmlrpc.php

    That test returned “XML-RPC server accepts POST requests only.” which is a valid result.

    2. We checked via cURL by running the following command from the terminal:

    curl -A “Jetpack by WordPress.com” -is -H ‘Content-Type: text/xml’ –data ‘<?xml version=”1.0″?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>’ ‘https://beinglibertarian.com/xmlrpc.php’ && echo

    The cURL test returned the following invalid result:

    —————
    HTTP/2 404
    date: Sun, 25 Feb 2018 13:46:05 GMT
    content-type: text/html; charset=UTF-8
    set-cookie: __cfduid=de2f7bfd67a8596e263586f9009625def1519566364; expires=Mon, 25-Feb-19 13:46:04 GMT; path=/; domain=.beinglibertarian.com; HttpOnly; Secure
    vary: Accept-Encoding
    expires: Wed, 11 Jan 1984 05:00:00 GMT
    cache-control: no-cache, must-revalidate, max-age=0
    link: <https://beinglibertarian.com/wp-json/&gt;; rel=”https://api.w.org/”
    strict-transport-security: max-age=15552000; includeSubDomains; preload
    x-content-type-options: nosniff
    expect-ct: max-age=604800, report-uri=”https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct”
    server: cloudflare
    cf-ray: 3f2b1bcf3cda2186-EWR
    —————

    Please provide this information above to your host so they can correct the server settings and allow cURL access.

    Once that is done, let us know. We will re-test the connection and continue to help you with any Jetpack issues you have.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Publicize no longer working’ is closed to new replies.