WordPress.org

Support

Support » Plugins and Hacks » Publicize just stopped posting images on Facebook

Publicize just stopped posting images on Facebook

  • NewsCorpse
    Member

    @newscorpse

    In the past couple of days Publicize has failed to post the image in my article on Facebook. Instead, it is posting a big “F” Facebook logo. When I manually post the article, the image shows correctly.

    I haven’t changed anything, and prior to the past couple of days it has been working fine for quite some time. I am presently using WordPress 3.6, and Jetpack 2.42

    Here is my most recent article that failed to post the image on Facebook (I have since posted it manually):
    http://www.newscorpse.com/ncWP/?p=10543

    Here is an example of a previous posting that used the Facebook logo:
    https://www.facebook.com/NewsCorpse/posts/713902281957903

    FYI: I have run the Facebook debugger and the articles look OK to me.

    Thanks for you help.

    http://wordpress.org/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 53 total)
  • Plugin Contributor Richard Archambault
    Happiness Engineer

    @richardmtl

    Hi,

    the article looks fine to me too, the image is of the right size. However, I have seen that FB might change their minimum image size to 1500px by 1500px, but I haven’t seen this be consistently applied. Maybe try posting another article but with a much larger image; if your theme allows it, you may be able to use it as the Featured Image for the post; Jetpack will pick up that Featured Image and use it as the og:image for FB. Try that and let me know if it gets picked up.

    NewsCorpse
    Member

    @newscorpse

    Thanks Richard.

    I can’t believe that Facebook would make the minimum image size 1500px by 1500px. That is HUGE. It’s twice the width of their cover image size. It makes no sense.

    My theme’s main column for content is only about 600px wide. Also, my theme does not use a featured image. Jetpack has always pulled the first image posted in my articles, and that is what I prefer.

    I noticed that the problem began around the same time that Facebook changed the way they displayed posts. They used to have the image left-aligned with the text to the right of the image. Now the image spans the width of the column and the text is below. Could that change have affected the way Jetpack interfaces with Facebook?

    Plugin Contributor Richard Archambault
    Happiness Engineer

    @richardmtl

    Well, I saw the 1500 by 1500 here:

    https://developers.facebook.com/docs/opengraph/howtos/maximizing-distribution-media-content/#tags

    They specifically mention 1500 by 1500; I don’t know if it will become a requirement one day.

    In any case, if your theme used Featured Images, they don’t even need to be displayed in your posts, BUT Jetpack will see them and send them to FB. Have a look at here to learn how to add support for Featured Images to your site:

    https://codex.wordpress.org/Post_Thumbnails

    An dlike I said, unless your theme explicitly uses them in the post, they won’t show up anywhere.

    Otherwise, as we both saw, the Facebook debugger returns no erros for the post, and the correct og:image tag is there, and the image in that post was larger than their minimum size, so I can’t really tell you what the issue is. I don’t think it’s a Jetpack issue, though.

    So, if you try the Featured Images and you still have problems, let me know!

    NewsCorpse
    Member

    @newscorpse

    FYI: Just to rule it out, I did a post with an image larger than 1500×1500. It still failed to display the image.

    I am aware of the featured image function, but I always include an image in my posts and have no need to declare a featured image. Jetpack has always worked without the featured image functionality. It has worked fine for as long as I’ve used it until about Sept 11, right around when Facebook changed the way they display posts.

    This has to be a Jetpack issue because I can post manually with no problem – Facebook displays the post and the image perfectly. Only when Jetpack posts is there a problem. That seems to be a pretty good indicator, to me, that something is going wrong between Jetpack and Facebook that is NOT going wrong between me and Facebook.

    Can you please do some more troubleshooting. I’m happy to help if I can. But this shouldn’t be working fine one day, then fail the next, for no reason.

    Thanks.

    Plugin Contributor Richard Archambault
    Happiness Engineer

    @richardmtl

    I just tried to Publicize a post right now, with an inserted image about the same size as your first one:

    http://reviewmysite.ca/testing-images-to-fb/

    And here’s the FB screenshot (I deleted the post right away):

    http://d.pr/i/4dEx

    As you can see, the image showed up in FB. Note again that this was NOT a featured image, just an image inserted into the post.

    I also tried a post with just a Featured Image, and no images in the actual post:

    http://reviewmysite.ca/post-to-fb-but-with-a-featured-image-only/

    screenshot: http://d.pr/i/Zohb

    Again, the image showed up immediately.

    My test site uses TwentyTwelve and normally I don’t have any other plugins active while I’m doing tests.

    So again, I don’t know what’s going on. I see nothing obviously wrong with your theme or you psosts. Maybe it’s because you’re posting to a page and not a profile, like in my tests? Or maybe it has something to do with your theme? Do you think you could switch temporarily to TwentyTwelve, deactivate your other plugins, and then try again really quickly, just to rule out Theme or Plugin interference somehow?

    NewsCorpse
    Member

    @newscorpse

    Well, I don’t know what’s going on either. I only know that my theme and plugins and everything else worked fine until around Sept 11. I changed nothing. The only difference that I noticed is the change that Facebook made to their display (as I noted above). I have always posted to a Facebook page, not a profile. Why did it work on the 10th and not on the 11th?

    I am uncomfortable messing around with changing themes because it would alter my site beyond recognition. Maybe I could try it overnight when traffic is lower, but I’m still uncomfortable. Do you think disconnecting Publicize and reconnecting would do anything?

    I still can’t get past the facts that the debugger shows everything OK, and that I can post manually without any problem. Why does it only fail when posting by Jetpack?

    Plugin Contributor Richard Archambault
    Happiness Engineer

    @richardmtl

    Hi!

    I have asked the developers to look into this one at this point. I’ll get back to you!

    NewsCorpse
    Member

    @newscorpse

    Thank you so much. I’m going nuts! 😉

    NewsCorpse
    Member

    @newscorpse

    Hey Richard,

    I assume you haven’t heard anything yet. However, I wanted to let you know about an odd occurrence that I observed since our last exchange.

    Sometimes when I paste a link manually into Facebook (and before clicking “Post”) it will grab a random image from my page that is not associated with the specific post. Then, if I do not click “Post” but instead delete the link, refresh the page, and then paste the link in again, it will pull the correct image.

    This has happened a few times. I thought it might help your developers to know this.

    Pepe Huerta
    Member

    @darkpepe

    I’m having the same problem. Publicize does not post the correct image in FB.

    This post:

    http://www.lagzero.net/2013/09/valve-anuncia-steamos-su-propio-sistema-operativo-para-jugar-chao-windows/ (with a featured image selected)

    Posted this on Facebook:

    http://grab.by/qwru

    That image is not even in the post!

    The OpenGraph tags are OK, and if you share the post using a share button, it works as intended.

    My guess, is that facebook needs to scrap the post first to get the OG tags, since the post is not published at the time that Jetpack submits it, facebook grabs whatever it can find… sometimes, it take several minutes to get facebook scrap the posts … so, that could be a problem when using publicize… but well, it’s just a guess.

    Plugin Contributor Richard Archambault
    Happiness Engineer

    @richardmtl

    Thanks to the both of you. we’re still working on it, but what DarkPepe sugests is something along the lines of what we’re thinking, though we have yet to confirm it and it could be something else entirely. I’ll definitely let you know when I have news.

    Pepe Huerta
    Member

    @darkpepe

    Richard, I’ve read in the past in FB’s documentation that the page info is pulled from the scrap process (can’t find the doc atm)… maybe just adding a delay on jetpack’s publishing action could solve the problem.

    Kind Regards.

    Hey Richard, I was just wondering if there has been any progress or anything else to report. Your last comment sounded like you guys had a lead. Is it panning out? Thanks.

    WPyogi
    Forum Moderator

    @wpyogi

    @newscorpse – just so you know, the JP team are on a work retreat right now…

    http://wordpress.org/support/topic/jetpack-staff-will-be-unavailable-until-october-7th?replies=1

    I’m sure they’ll get back to this as soon as they can :).

    wickedmike
    Participant

    @wickedmike

    I’ve many websites with several feeding into http://www.facebook.com/loveknysna. This has been an ongoing problem for a month now. Looks awful without a picture (plus it doesn’t pull intro text sometimes). An ugly url by itself doesn’t get clicks so makes a lot of effort (e.g. if the article’s thousands of words) go down the drain!

Viewing 15 replies - 1 through 15 (of 53 total)
  • The topic ‘Publicize just stopped posting images on Facebook’ is closed to new replies.