WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
Publicize is not working for Facebook (10 posts)

  1. leonardogsouza
    Member
    Posted 11 months ago #

    I don't have OG issues (as per https://developers.facebook.com/tools/debug)however somehow Publicize is not working for Facebook. This is really a pain, I schedule my posts and when I go to Facebook to check comments and stuff, where is my post? So frustating.

    https://wordpress.org/plugins/jetpack/

  2. lojze
    Member
    Posted 11 months ago #

    I have the same problem as Publicize is not posting to Facebook and Twitter. Even when I create a new post, the Publicize option is not there.

    Any help available?

  3. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 11 months ago #

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

    If you contact us through our form, please make sure to include a link to this thread in your message.

  4. leonardogsouza
    Member
    Posted 11 months ago #

  5. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 11 months ago #

    When you share a post on Facebook, or when Jetpack Publicize publishes a post to your Facebook page, Facebook crawls the page and looks for Open Graph meta tags in the head to build a complete post preview (with an image, title, description, ...).

    You can see what Facebook sees by entering one of your posts' URLs in Facebook Debugger:
    https://developers.facebook.com/tools/debug

    I would recommend putting the URL of a post that isn't publicizing properly into the Debugger tool to see if you have any errors. If there are any errors, Facebook will reject the post when it’s shared using the Facebook API.

    For example:

    https://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Fwww.zunkabitz.com%2Fcomo-os-animais-veem-o-mundo%2F

    It mentions an error in regards to the article:section tag. You have 2 on your site, so I can't be certain which one is the problem, but I'd bet it's this one:

    <meta property="article:section" content="Ciência" />

    See how the accent is written out using an HTML entity? I suspect Facebook may be having problems with that. Since your OG tags are output by Yoast's SEO plugin and not by Jetpack, you'll have to ask them for support for that:

    http://wordpress.org/support/plugin/wordpress-seo

  6. leonardogsouza
    Member
    Posted 11 months ago #

    This is weird because I didn't have any problem with this post specifically..

  7. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 11 months ago #

    Ok, then can you give me the URL of a post that DID give you problems?

  8. lojze
    Member
    Posted 11 months ago #

    I have problems with ALL, as I can not upload them to FB/Twitter.

    An example: http://www.xn--znianje-fxb.si/coupon/lidl-naj-vas-vrt-zazivi/

  9. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 11 months ago #

    lojze:

    Could you please start your own thread, as per the Forum Welcome?

    http://wordpress.org/support/plugin/jetpack#postform

    Thank you!

  10. lojze
    Member
    Posted 11 months ago #

Reply

You must log in to post.

About this Plugin

About this Topic