WordPress.org

Support

Support » Plugins and Hacks » Jetpack by WordPress.com » [Resolved] Publicize is not posting on Facebook

[Resolved] Publicize is not posting on Facebook

  • NewsCorpse

    @newscorpse

    I activated Publicize a couple of days ago but can’t seem to get it to post anything on Facebook.

    The activation went through correctly, so far as I can tell. It said that it connected to my Facebook account and gave me the options to select my profile or my page (I selected my page). I have the options in my Publish box for “Edit” and “Settings.” Under “Edit” it lists my Facebook page and the box next to it is checked.

    Under “Settings” it shows my Facebook page and says “Shared” next to it. I tried it with and without checking “Make this connection available to all users of this blog?”

    I’ve written several new posts and none of them showed up on Facebook (although they did show up via NetworkedBlogs which I am using and hoping to quit if I can get this to work).

    My blog is http://www.newscorpse.com/ncWP/
    My Facebook page is http://www.facebook.com/NewsCorpse
    It is not a page-only Facebook page.

    I am using WP 3.4.2, Jetpack 2.0.2, and Firefox 17 (I tried IE also) on a Windows 7 PC.

    Did I cover everything? I would really appreciate some help to get this working.

    Thanks, Mark

    p.s. A couple of quick questions. How long should it take for a post to show up on Facebook after publishing it on my site (If I get it to work)? Also, It appears to default to the wp.me shortlink. Is it possible for it to use the regular permalink?

    http://wordpress.org/extend/plugins/jetpack/

Viewing 15 replies - 16 through 30 (of 34 total)
  • I am having the exact same problem as agermanucf, except I have FB and LinkedIn set up, but none of them seem to be working.

    When I publish a Post, the boxes are checked so you would think it is being shared. When I come back to the Post the boxes are automatically unchecked and it will not let me recheck them.

    I have disconnected and reconnected, and still no go.

    I checked the Debug and Token issue you mentioned and they are not blank.

    I also have an image, but only on hover over text (for a Amazon link).

    The blog I need help with is thecatholiceducator.org.

    Also, if I just update a post will that initiate a publicize to FB and LinkIn or do I have to publish a new post to test the function?

    Any insight would be greatly appreciated!

    Thanks, David

    Plugin Author Jeremy Herve

    @jeherve

    Jetpack Mechanic

    @thecatholiceducator Could you walk me through the steps you follow to publish a post?

    Could you also let me know if you use any plugins that may affect the status of your posts, or any caching plugins?

    if I just update a post will that initiate a publicize to FB and LinkIn or do I have to publish a new post to test the function?

    Publicize only works with newly published posts, so it won’t be triggered if you update a post.

    Had a few issues of my own posting to Facebook. It was displaying full url instead of the post title. Some posts wouldn’t appear on Facebook, posts with no images etc. I was trying to work out what I had done since I migrated my WP site to another host and find out how to fix these problems. Then by chance I spotted that the default post format (in settings/writing) was set to ‘status’. I changed this to ‘standard’ and all seems well publicizing to Facebook. Titles correct, images appear, all looks good. Maybe something to look at if you’re also having problems.

    Will try scheduled post problem later tonight and see if that’s also cured.

    I’m using the montezuma theme by the way.

    Jeremy, thanks for your reply. I just typed my post directly into the wordpress editor and hit publish. I had all the same symptoms of agermanucf previously. Kinda new to this, and I don’t know what plugins might affect the status of my posts(not really sure what that means) or which ones would cache. I don’t have many plugins, essentially just JetPack, WordPress SEO, Google Analytics, Askimet, and Amazon Associate. Before I installed Jetpack, I installed Facebook for WordPress. I tried to set that up but it was very confusing. I just realized that I have that still installed, but DEactivated. I will also have to try a test post to see if it works after I reset the connection from both the WP and FB sides; I only updated my previous post after reset. I’ll try a new popst and get back to you. Thanks.

    Jeremy, it works now. The reset did actually work. It’s just that I tested it in a faulty manner by hitting update instead of posting anew. Thanks very much for your help. I appreciate it..

    Scheduled posts now working fine.

    Spoke too soon… A scheduled post failed to make it to Facebook this evening.

    Plugin Author Jeremy Herve

    @jeherve

    Jetpack Mechanic

    @newstart Designs Could you post your site URL here, or email it to me, so I can have a closer look?

    Hi Jeremy,
    newstartdesigns.uhostfull.com is the url at the moment.

    Thanks.

    I continue to have the same problem with jetpack publicize not posting to Linkedin nor Facebook. I have only made a few posts since my last comments here, and have not had a successful post to Facebook or LinkedIn. Before my most recent post I updated all my plugins, including Jetpack. I disconnected from, and reconnect to, LinkedIn and Facebook exactly as instructed in the documentation. Both seemed to be ready to publicize. The Facebook publicize had “(shared)” next to it on the settings/sharing page (though LinkedIn did not. Yet both appeared ready.) Both were checked when I selected edit before I posted. After I posted, neither publicized and now both are unchecked (under edit on the post page) and will not allow me to check them. Please help.

    Plugin Author Jeremy Herve

    @jeherve

    Jetpack Mechanic

    @newstart Designs I don’t seem to be able to access your site at the moment. Have you switched to a different URL?

    @thecatholiceducator Something seems to affect the Publicize options in your post editor. Out of all the plugins you mentioned earlier, Amazon Associate is the only one I don’t know. Could you try to deactivate it, and let me know if it helps when writing a new post? Could you also try to deactivate Post Ratings, as well as other plugins you may have installed recently?

    Thanks!

    I’m having the same issue on LinkedIn where my WordPress posts do not show up. I’ve had a WordPress blog on a GoDaddy-hosted site for about 5 months. The Publicize plugin worked fine at first but now it seems to work sporadically for sending my postings to LinkedIn. Today it did not work.

    I deactivated the only plugin I had on the list, Better WP Security, with no success. I am able to successfully access the XML-RPC file.

    All of my plugins are up to date. I’m using the Twenty Twelve theme with no customization.

    Any suggestions?

    I scheduled two posts that didn’t publicize — even through previous ones had.

    The site is http://www.zixi.com.

    Now that the posts have been published, when I edit the publicize settings, I can see my text and the short link, but it wasn’t shared with Twitter, LinkedIn and/or Facebook.

    Would appreciate any suggestions.

    I’m having no luck with posting to Facebook or Twitter.

    My site is http://comic.matazone.co.uk

    The site is using the Comic Easel plugin, which might be causing the problem, and all posts are scheduled rather than live, but the sidebar of the posts does say that they will be shared to Facebook. I suspect that it’s probably Jetpack having the problem, not Comic Easel, given that there are numerous other people having the same problem.

    Is there anything I can do to help you diagnose the issue?

    Plugin Author Jeremy Herve

    @jeherve

    Jetpack Mechanic

    @matazone Could you please start your own thread, as per the Forum Welcome?
    http://wordpress.org/support/plugin/jetpack#postform

    Thank you!

Viewing 15 replies - 16 through 30 (of 34 total)
  • The topic ‘[Resolved] Publicize is not posting on Facebook’ is closed to new replies.
Skip to toolbar