WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Publicize is not posting on Facebook

[Resolved] Publicize is not posting on Facebook

  • NewsCorpse
    Member

    @newscorpse

    I activated Publicize a couple of days ago but can’t seem to get it to post anything on Facebook.

    The activation went through correctly, so far as I can tell. It said that it connected to my Facebook account and gave me the options to select my profile or my page (I selected my page). I have the options in my Publish box for “Edit” and “Settings.” Under “Edit” it lists my Facebook page and the box next to it is checked.

    Under “Settings” it shows my Facebook page and says “Shared” next to it. I tried it with and without checking “Make this connection available to all users of this blog?”

    I’ve written several new posts and none of them showed up on Facebook (although they did show up via NetworkedBlogs which I am using and hoping to quit if I can get this to work).

    My blog is http://www.newscorpse.com/ncWP/
    My Facebook page is http://www.facebook.com/NewsCorpse
    It is not a page-only Facebook page.

    I am using WP 3.4.2, Jetpack 2.0.2, and Firefox 17 (I tried IE also) on a Windows 7 PC.

    Did I cover everything? I would really appreciate some help to get this working.

    Thanks, Mark

    p.s. A couple of quick questions. How long should it take for a post to show up on Facebook after publishing it on my site (If I get it to work)? Also, It appears to default to the wp.me shortlink. Is it possible for it to use the regular permalink?

    http://wordpress.org/extend/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 34 total)
  • NewsCorpse
    Member

    @newscorpse

    Is anyone reading these posts?

    Since I posted this, one of my blog posts made it to Facebook. The others have not. Can anyone explain what’s going on and how to fix it?

    Thanks.

    Plugin Author Jeremy Herve
    Jetpack Mechanic

    @jeherve

    Your posts should appear on Facebook a few minutes after their publication on your blog.

    Could you try to reset the connection to Facebook, as explained here:
    http://jetpack.me/support/publicize/#reconnecting-facebook

    If that doesn’t help, could you give me more information about these blog posts? Do you write from your WordPress dashboard, or do you use a third party application to write your posts? Could you also let me know if you publish your posts right away, or if you schedule them to be published later?

    Thanks!

    NewsCorpse
    Member

    @newscorpse

    Thanks for your response, Jeremy.

    I reset the connection as you described and ran a test last night. That posted on Facebook within a couple of minutes. However, I posted a new article about half an hour ago and it still has not shown up on Facebook.

    More Info:
    I write my posts by going to “Post – Add New” in WordPress (is that what you mean by the Dashboard?). I publish my posts right away.

    Also, the last time I got this to work, it successfully posted the very next article I published, then never again. This time, after resetting, it also posted the next article I published (the test), but not the one after that. I don’t know if that’s significant or not.

    Plugin Author Jeremy Herve
    Jetpack Mechanic

    @jeherve

    Could you go to the Jetpack menu in your dashboard, and click on the Debug link at the bottom of the page?

    If the Token value is empty, could you try to disconnect / reconnect Jetpack to your WordPress.com account thanks to the button at the top of the page?

    Let me know if this helps.

    NewsCorpse
    Member

    @newscorpse

    The token value(s) (blog and user) are not empty.

    Any other ideas?

    Plugin Author Jeremy Herve
    Jetpack Mechanic

    @jeherve

    I am afraid I am out of ideas for now.

    I have warned our developers about the issue, and I will keep you posted!

    NewsCorpse
    Member

    @newscorpse

    Oh darn. I really want to use this. I just reset the connection to Facebook again to see if anything would happen, but no luck.

    I appreciate your help and hope to hear from soon if you locate the problem. Please let me know if there is anything I can do to help troubleshoot it.

    Plugin Author Jeremy Herve
    Jetpack Mechanic

    @jeherve

    Our developers looked at your connection, and everything seems to be set up properly on our end.

    Could you try to reset the connection to Facebook once again, following the instructions here:
    http://jetpack.me/support/publicize/#reconnecting-facebook

    The important step there is to remove the application on Facebook’s site as well:
    https://www.facebook.com/settings?tab=applications

    Let me know if that helps.

    NewsCorpse
    Member

    @newscorpse

    Hey Jeremy,

    I discovered the problem a couple of days ago and have tested the solution since then. Apparently Publicize doesn’t like it when you have an image in your post that uses a relative address. So I started using the absolute address and now Publicize is posting to Facebook.

    I’m not sure why Publicize requires an absolute address. I know that NetworkedBlogs doesn’t have a problem with relative addresses and there is no problem when I post to Facebook manually.

    I discovered the problem by using a Facebook debug tool that you might find useful in diagnosing future problems: https://developers.facebook.com/tools/debug

    Thanks for you help.

    Plugin Author Jeremy Herve
    Jetpack Mechanic

    @jeherve

    Nice catch! I have warned our developers about the problem. I will keep you posted!

    agermanucf
    Participant

    @agermanucf

    I am having the exact same problem, except the Post is not publicizing to any of my connected networks. I only have Yahoo, FB and Twitter set up, but none of them seem to be working.

    When I publish a Post, the boxes are checked so you would think it is being shared. When I come back to the Post the boxes are automatically unchecked and it will not let me recheck them.

    I have disconnected and reconnected, and still no go.

    I checked the Debug and Token issue you mentioned and they are not blank.

    What is meant by relative and absolute links with an image? I do have an image in my Post, and I am also using Zemanta which provides a “Related Article” insert at the bottom.

    The blog I need help with is http://www.bgwindowfashions.com.

    Any insight would be greatly appreciated!

    Thanks, Andy

    Andrewjmarino
    Member

    @andrewjmarino

    Same problem. My December monthly post did not publicize. Everything looks checked and correct to me.

    Andrew

    December 2012

    https://www.facebook.com/pages/Banteay-Chhmar-CBT/111910152222235

    Plugin Author Jeremy Herve
    Jetpack Mechanic

    @jeherve

    @agermanucf I had a look at your site, and it seems that your hosting provider may have made some changes to your server configuration.

    Can you please try installing the Jetpack Compatibility Plugin so we can see some additional information from your site?

    1) Download the plugin from http://plugins.svn.wordpress.org/jetpack/branches/jetpack-compatibility-test.zip
    2) Upload the plugin to your site via Dashboard -> Plugins -> Add New.
    3) Activate the plugin and go to Plugins -> Jetpack Compatibility Test.
    4) Click the “Select All” button.
    5) Send the results of the test, via this contact form:
    http://en.support.wordpress.com/contact/?jetpack=needs-service

    @andrewjmarino It seems you have made some changes to your Facebook account. Could you try to reset the Publicize connection, as explained here:
    http://jetpack.me/support/publicize/#reconnecting-facebook

    agermanucf
    Participant

    @agermanucf

    Thanks for the help Jeremy! I’ve followed your directions and pasted the results on the contact form.

    Hope this helps!

    Andrewjmarino
    Member

    @andrewjmarino

    It seems to be working for me now. I did the resetting. I only do one post/month, so it took me a while to check on this.

    Thanks

    Andrew

Viewing 15 replies - 1 through 15 (of 34 total)
  • The topic ‘[Resolved] Publicize is not posting on Facebook’ is closed to new replies.