Support » Plugin: Jetpack by » Publicize: Having Trouble Adding Facebook-App Gets Stuck

Viewing 15 replies - 1 through 15 (of 32 total)
  • Plugin Author Beau Lebens


    A couple of questions:

    – is the Page “published” within FB?
    – do you have a “normal” profile account assigned as the admin/manager of the Page?
    – can you provide the URL to the FB Page?
    – are you using the latest version of Jetpack (2.0.2)?


    1. Yes

    2. I initially created the page separate from my personal Facebook, using a different email. I did eventually add my personal profile as an admin/manager, but that profile is not the primary manager.


    4. Yes

    Thank you. 🙂


    Plugin Author Beau Lebens


    I got an email notification that you had said you had deactivated your personal account, but it looks like you edited that. Is that because you’ve reactivated, or because you realized that wasn’t the case?

    I think it might actually be related, because the way that we’re accessing Facebook currently requires that there is a profile/user account associated with the FB Page.

    If your profile is deactivated, can you try activating it and see if that allows you to connect?

    It might also be related to the fact that you’re not the primary manager — is the primary manager the other account that you created? Is it possible to change that to a “normal” user account?

    I can’t connect my blog to Facebook via Jetpack’s Publicize feature. Clicking on the “Add new Facebook Connection” link brings me to Facebook to the WordPress App. When I click “Go to App” the page just refreshes and nothing happens. I do see the url change to “” but clicking on “Go to App” repreatedly does nothing except refreshing the page.

    The blog I need help with is

    I had reactivated but in the end I decided to just delete my personal account as a manager of the page altogether (and deactivate my personal account again). It didn’t make a difference. I guess I’ll just have to uninstall/reinstall JetPack and do it that way. If that doesn’t work, then I just won’t connect my Facebook page.

    Thanks anyway. 🙂

    Plugin Author Beau Lebens


    @kareldonk: if you just start the connection process from the beginning, does it always do the same thing?

    What sort of Facebook account do you have/are you logged into? (normal user account, Page account, something else?)

    Beau, it worked via FireFox but not via IE9…

    Plugin Author Beau Lebens


    Interesting, thanks for the info, I’ll check it out in IE and see if there’s something browser-specific going on.

    I ended up removing JetPack and reinstalling. I reactivated my personal account on Facebook which restored my admin status on my blog’s FB page. It all worked fine this time, so it seems that it was the fact that my personal account had been deactivated and it was the only admin beyond the ‘page creator’.

    Thanks for the help!

    I want to connect new site to Facebook page with Jetpack publicize. I’m the admin of a multi-blog installation. All existing blogs are properly linked. When I try to add the link to new blog using publicize setup, it immediately connects to my personal Facebook page acccount giving me any option to switch the connection to one of my Facebook pages. I am an administrator of those pages.

    Since I did this, easily, for other blogs in the same multi-blog site, I’m baffled. Don’t recall needing any special trick to get publicize to give me the option to post to a page . . .

    I’m having difficulty linking to my Facebook page. I am an administrator of a couple of pages, but they don’t show up in the publicize connection box. The only choice there is my Facebook account (which I don’t want). The section for connecting to pages is blank.

    This is for a new site on a multi-site blog. All the others are linked, via publicize, to my Facebook page. Did this months ago, but there was no problem back then. The page showed up on the connection screen and I selected it.

    Is there a trick to getting pages the show up on the connection screen?

    I can’t link to my FB Page – when I go to add FB account – it sends me to my personal account. I am the admin but don’t want autoposts to go to my account but to the Page
    I think I am having the same issue as teamjli in the post above.


    +1 not being able to connect my fb Page to the Publicize facebook connect.
    I am the administrator of a few pages and i control them succesfully from my FB account.
    When i try to connect Publicize it shows only my personal FB profile, which i don’t want to connect. I have just updated to WP 3.5.2 and I am using Chrome. Could it be a general issue as the 2 people above me appear to have the same issue and their posts are from today?

    Well, like kambone, I upgraded to 3.5.2 this morning. I’m using Firefox. Don’t think it’s the browser.

    Using “inspect element” (right click FB link to personal account on Publicize settings page) I can see how the code differs (the rest of my multi-sites are already posting to the FB page so I can also see the correct code), can even change it, but haven’t found a way to save the changes . . .

    I’m not cool enough to know how to access the same bit of code in an editing screen. But I know I didn’t go through all that before when I set this up for the other sites.

    When I do the publicize setup it brings up a window with a section where my Facebook pages should be shown but they’re not. Same problem for kambone and harborseditor?

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘Publicize: Having Trouble Adding Facebook-App Gets Stuck’ is closed to new replies.