Support » Plugin: Jetpack by WordPress.com » Publicize don’t use manual excerpt when posting to LinkedIn

  • Resolved Just1M

    (@just1m)


    Hello,
    I’m reporting an issue that I have with Publicize and LinkedIn. When I define a manual excerpt Publicize correctly send it to Twitter but not to LinkedIn, where the manual excerpt is replaced by an automatic excerpt (first X characters of the post content). See the attached screen capture.

    Twitter on desktop (OK, manual excerpt shown): https://ibb.co/bs7597
    Twitter on mobile (OK, no excerpt at all): https://ibb.co/mn1Xp7
    LinkedIn on desktop (KO, auto excerpt shown): https://ibb.co/c67u2S
    LinkedIn on mobile (KO, auto excerpt shown): https://ibb.co/dH6Abn

    Is there an explanation? Is it a bug?
    Thank you.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Stef

    (@erania-pinnera)

    Hello @just1m! Sorry to hear about the trouble you’re having!

    Could you post your site URL here, so I can have a look?
     
    If you want it to remain private, you can also contact us via this contact form:
    Contact Support

    Thanks a lot in advance!

    Hello,
    I’m sorry but I can’t, I have trashed these posts both from my website and from my social profiles because I don’t want those tests to stay public… I don’t have a “sandbox” website nor a sandbox LinkedIn profile.
    I have no doubt you could reproduce a similar situation on your side.

    Plugin Contributor Stef

    (@erania-pinnera)

    Ah, I see that – it’s a pity 🙁
    I tried replicating the issue on my end but all worked in my site.

    Can you try posting/sharing again on LinkedIn and let us know if the problem persist? Happy to check on the posts if the issue occurs again.

    Look forward to your reply, thanks!

    Be careful: when you set a “featured image”, no more excerpt is posted to LinkedIn (nor Twitter). As my latest posts all have a featured image I’m going to refer to a quite old post entitled “Synthesis on How to store my design data safely”.
    Original website: https://gotomation.info/
    Twitter’s Publicize post: https://twitter.com/justinmassiot/status/740206791242305536
    LinkedIn’s Publicize post: https://www.linkedin.com/feed/update/urn:li:activity:6145972477949411328

    Plugin Support Tracy

    (@tmmbecker)

    Could you give us a direct link to that post? The redirects from both Twitter and LinkedIn are directing back to the home page of your site. Thanks!

    Plugin Support Tracy

    (@tmmbecker)

    Yes! Thank you.

    I can see that there is a summary for the Tweet but not for LinkedIn now. Are you only seeing this problem when the post does not have a featured image?

    If you can confirm that, we can run some tests here to see what we can uncover.

    Publicize seems to replace any kind of excerpt by the featured image if there is any. So yes, the bug is present only without a featured image, at least on LinkedIn and Twitter. Look at my Twitter feed for an example.

    Plugin Support Tracy

    (@tmmbecker)

    I’ve tried to test this a few times today, but it seems that LinkedIn is having some troubles with my feed updating. I’ll take a peek at it again in a few days and go from there.

    Thanks for your patience!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Publicize don’t use manual excerpt when posting to LinkedIn’ is closed to new replies.