Support » Plugin: Jetpack by WordPress.com » Publicize doesn't use own url-shortener

  • Resolved Heiko

    (@heiko2107)


    I’ve installed the “Yourls: WordPress to twitter” plugin for using my local yourls instance for creating shortlinks to my posts.
    Unfortunedly the publicize plugin doesn’t create yourls shortlinks when publishing new posts. So ATM the publicize plugin is useless for me.

    http://wordpress.org/extend/plugins/jetpack/

Viewing 4 replies - 16 through 19 (of 19 total)
  • BTSgirl

    (@btsgirl)

    great thread, thanks for the updates and suggestion of which plugin!

    Hi Jeremy,

    I have JetPack installed and the share icons for Publicize. I also have the WP Bit.ly and your Jetpack for shortlinks sharing plugin installed. I am using a custom bit.ly URL shortner and it’s working for Twitter, but not Facebook.

    For example – When you click Twitter, it includes the mrjust.in URL (custom bit.ly shortner). This is good! When you click Facebook, it’s showing the full URL justinfrechette.com. This is bad!

    Is there any way to get Facebook to show the mrjust.in URL when sharing? Thanks for your help!

    EDIT: It appears that the custom URL shortner does work with Facebook… FB, apparently, displays the destination URL in the post but links to the shortner.

    WordPress now can be hosted in Google Cloud infrastructure but the environment is controlated. For instance, modules utilizing cURL don’t work as Google App Engine team disabled this lib and recommend to use streaming using an standard method.
    Due to all this many plugins need to be modified in order to work on the platform.

    https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&ved=0CCsQFjAA&url=https%3A%2F%2Fdevelopers.google.com%2Fappengine%2Farticles%2Fwordpress&ei=FXBHUtmRCYj49gSL64CQAQ&usg=AFQjCNGgH9XQOWQQEOLFVpGuu1r0T9hS7g&bvm=bv.53217764,d.eWU

    I write all the above becuase I’m having trouble to make work publicize and WP bitly. Although WP bitly first choice is cURL is carefully thought to fall back and use an standard method.

    So, in theory Publicize should pick up WP bitly and post using this url shortener. Well, this is not happening to me and I hope someone could help me on this.

    I’m on WP 3.6.1, have the latest of jetpack, Publicize is configured and previously working with wp.me. I tried having enabled and disabled Wp.me shortlinks and bitly never works. Full url is posted.

    Please help.

    Problem solved. I modified WP bitly according to the GAE documentation and worked.

    Thanks

Viewing 4 replies - 16 through 19 (of 19 total)
  • The topic ‘Publicize doesn't use own url-shortener’ is closed to new replies.