Support » Plugins and Hacks » [Resolved] Publicize doesn't use own url-shortener

[Resolved] Publicize doesn't use own url-shortener

  • I’ve installed the “Yourls: WordPress to twitter” plugin for using my local yourls instance for creating shortlinks to my posts.
    Unfortunedly the publicize plugin doesn’t create yourls shortlinks when publishing new posts. So ATM the publicize plugin is useless for me.


Viewing 15 replies - 1 through 15 (of 19 total)
  • yes it does not .

    Plugin Author Jeremy Herve


    The Publicize module doesn’t allow you to use your own custom shortlinks yet, but we plan to add this feature to Jetpack very soon.

    Make sure to have a look at the changelog next time you see a Jetpack update in your dashboard! 😉

    Awesome news. Thank you!

    @ Jeremy Herve: I am still waiting to see that ! Hope this will come soon.

    Plugin Author Jeremy Herve


    This has actually been implemented. if you use a custom URL shortener like Bit.ly or Yourls, Publicize will use your custom shortlink instead of the wp.me shortlink.

    You still need to use a separate plugin to create your own custom shortlinks though: once your plugin has created them, Jetpack Publicize will use them!


    I use the bit.ly linker plugin, and on publishing a blog post, this link was generated by bit.ly linker:


    Which is what I want, however, in the tweet that was created:

    The following URL was created:


    Which isn’t what was expeceted.

    Am I doing something wrong? Is there another plugin that I should be using?



    Plugin Author Jeremy Herve


    I had a look at your site, and your test post doesn’t seem to use the Bit.ly shortlink yet:

    You’ll want to use another plugin that updates the shortlink value, so it can be used by Jetpack Publicize.
    Here is an example:

    Hello Jeremy,

    Thanks for getting back to me!

    I have just installed WP Bit.ly, and I am happy to say that this is now working as expected!

    Thanks! Hope you have a great New Year!


    Question-is there a way to connect the bitly account to the share buttons beneath the post so the URL that is shared on Twitter is shortened? I installed the WP Bitly plugin and it works but when I try to tweet the post using the share button, it still lists the complete url and it is not shortened. Can you update that if you haven’t already? That’s a big issue.

    Plugin Author Jeremy Herve


    @toughcookiemommy Athough we do not use custom shortlinks in the sharing buttons yet, that’s a good suggestion.

    We’ll consider adding this feature in a future Jetpack update!

    In the meantime, you can install this small plugin on your site to use custom shortlinks with the Jetpack sharing buttons:

    Is that your own plugin Jeremy? Is it not available in the WordPress Gallery?

    Call me paranoid, just not sure about installing that, knowing nothing about it 🙂



    Plugin Author Jeremy Herve


    It is indeed a small plugin I just created earlier today. You can install it, it should work!

    I guess I could submit it to the plugin repository, but it’s a small plugin so I’m not sure that’s worth it 🙂

    Hey, I publicized a post to Facebook and Twitter and the problem is that it sends two updates to Twitter, each is the same but has different short urls (fb.me and wp.me) I really don’t care which one is used (I like the wp.me), but I’d rather have only one tweet go out. Any ideas?

    Oh okay I just tried publicizing only to Twitter and it did one tweet with the wp.me short url.

    So is there a way to stop it from making another tweet with the Facebook short url when I want to share the post to Facebook in addition to Twitter?


    Plugin Author Jeremy Herve


    The update using fb.me is created by another application: it could be the Facebook application in your Twitter account.

    Could you check your Twitter app settings, and revoke access for all the apps you don’t use anymore?

    That’s it exactly!

    Ya I am building this website for a friend’s business and didn’t even think to check what else their twitter account was connected to or that that would affect anything.

    Thanks for the quick response!

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Resolved] Publicize doesn't use own url-shortener’ is closed to new replies.