Support » Plugin: Jetpack by WordPress.com » Publicize doesn’t publish each post

  • Resolved mixos

    (@mixos)


    Hello,

    We are using publicize to publish our new posts on our social and we noticed that when a post is saved as “pending review” or “draft” by a user, then when published by admin it will not publish to our social. We are using latest version of jetpack and WordPress.

    Any help on this matter would be greatly appreciated.

    Mike

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor lamday

    (@lamdayap)

    Could you post your site URL here, so I can have a look and run some tests?

    If you want it to remain private, you can also contact us via this contact form:
    Contact Support

    Thanks for getting back to me.

    Here is our URL: http://www.electronics-lab.com

    Mike

    Plugin Contributor lamday

    (@lamdayap)

    Thanks for sending those. The first thing I wanted to check was your site’s connection to Jetpack and it seems fine.

    In order for Publicize to work, the user who’s set as the author will need to have accounts added for Publicize, if they haven’t connected any social media accounts to Publicize then it won’t run for that particular user.

    The other way around this is to have one user add the accounts to Publicize and make the account global by ticking ‘Make this connection available to all users of this blog’.

    Under Publicize Connection settings i checked “Connection available to all administrators, editors and authors” will that make the trick?

    Thanks for pointing me to this.

    Plugin Contributor lamday

    (@lamdayap)

    Hi there,

    Thanks for getting back to us. Sorry about the delay in writing back. Yes that will definitely do it, what it does is allows all users who post to be able to use the Publicize connection, regardless of whether they have connected their own Publicize accounts or not.

    mixos

    (@mixos)

    Thanks, that have worked.

    Best
    Mike

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.