Support » Plugin: Jetpack by WordPress.com » Publicize Does Not Work

Viewing 15 replies - 16 through 30 (of 41 total)
  • I’ll update the cron.

    What does the ?doing_wp_cron parameter do that it doesn’t without it? Curious.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    What does the ?doing_wp_cron parameter do that it doesn’t without it? Curious.

    That’s how an alternative Cron job can be triggered. WordPress will add that query string if you use an alternative Cron job:
    http://wordpress.stackexchange.com/a/12778

    Jeremey, I did have ‘Missed Schedule’ running before that did affect the Chron operation but when this started appearing I removed it. So as of right now I do not have anything that is affecting my publicize other than Jetpack. Wondering if Godthor noticed the subscribers didn’t get their email or not. As I agree with what he posted in that my social media didn’t go out but also my subscribers didn’t either. And as I mentioned before, doing a manual publish, all works fine. It’s only with scheduled and like Godthor, I haven’t made any changes to any plugins, added anything or remove anything else really with my blog’s functionality in quite some time. All this started happening at Jetpack 4.2.1 and WP 4.6 release time.

    I don’t use the subscriber email feature, so I can’t comment on that.

    Godthor any chance you might be willing to subscribe yourself to it and then see if you get the email? My guess is you won’t because the publicize sends out to social media and subscribers at the same time. And when your problem started happening so did mine. Did you happen to notice it after getting WP 4.6?

    I’ve subscribed.

    Yes, the timing coincides with WP 4.6. My last publicized post was on the 16th, and I updated to 4.6 on the 17th.

    That’s what I have come down to. My guess is it’s something that needs to be changed in Jetpack do match the WP update. Personally, I don’t want to make changes to any configure file because I am totally not technical and don’t want to create more problems. So for now I’ve been manually triggering the posting from my dashboard. I post once a day and have FB, google plus and Twitter and about 30 subscribers.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    The problem isn’t linked to WordPress 4.6. It’s caused by some of the changes we’ve made in Jetpack 4.2. So far, it seems to affect folks using an alternate Cron instead of WordPress’ default scheduling system, wp-cron.

    @andrew Did you have the chance to check your site’s wp-config.php, and see if there was any mention on Cron there?

    Jeremy, I know this might sound silly, but I don’t even know where to find the WP-config.php? Remember, I have Managed WordPress and have pretty much only done front end stuff as I don’t like to complicate things. Let me know how to locate that and I can at least look to see.

    On a side note, I actually got my publicize to work correctly today. I had a scheduled posting at 3:30pm. At 3:46, the post went out and so did the social media and subscriber email. I changed nothing but yesterday and all previous days since 4.6 it didn’t work. I was just going to also say that I didn’t have the problem on WP 4.5 and Jetpack 4.2.1. It was only when it went to WP 4.6 that I noticed the change. And I was still running 4.2.1 initially when I got the problem with 4.6.

    Anyway, when I had “Missed Schedule” plugin connected, it definitely wasn’t working with the scheduled posts. And I only used that plugin before because I don’t have much traffic to my site so I was running a job to get my blog to post more around the time it was scheduled for.

    But right now I’ve been having to trigger it myself by going to my site. But again, at least today, it did seem to go out acceptably for the first time this week. 🙂

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    I don’t even know where to find the WP-config.php?

    This tutorial should help you locate that file:
    http://www.wpbeginner.com/beginners-guide/how-to-edit-wp-config-php-file-in-wordpress/

    when I had “Missed Schedule” plugin connected, it definitely wasn’t working with the scheduled posts.

    It sounds like that plugin might have been the culprit. If you’re looking for an alternative way to make sure your posts get published in time, I’d recommend enabling Jetpack’s Monitor module. When that module is active, our monitoring agent will visit your site every 5 minutes, to check if it’s accessible. That means you’ll get a visitor every 5 minutes, and that visit will trigger WordPress’ scheduling system if needed.

    Unfortunately, after looking at the tutorial, Managed WordPress under Godaddy don’t let you access it. It’s protected so you don’t screw things up. That’s at least as far as I can see.

    I must be honest and say that I’m not sure why you wanted me to look in there only for the fact that I don’t have any plugins active that affect my processing of a blog at this time. It was just that “Missed Schedule” that worked fine until that last release. I just can’t figure out why it didn’t work yesterday because I had it deactivated yesterday as well. So I’m still concerned there’s an issue going on.

    As for the jetpack setting, I just activated the monitor. So basically keeping that part of Jetpack active will be like someone looking at my site and thus it will trigger a “Missed Schedule” if that happens? And will it slow down my site at all or can it affect the cron at all negatively with this issue you are looking into already?

    Just wanted to report that my blog posted find today after activating the Monitor that you suggested Jeremy. All the publicize and subscribers worked fine. I’m guessing it was the Missed Schedule plugin combined with the software updates for WP and Jetpack that caused it? I’ll continue to check in and let you know if anything comes up. I love the monitor option by the way. Wished I had known about it a long time ago!!! 🙂

    I also have a missed schedule plugin. It’s called ‘WP Missed Schedule’ made by the sLaNGjI’s Team. Currently on version Version 2014.1231.2016.1.

    That’s the plugin that made mine stop working adminroidturf. Turn it off and the set the Monitor to ON in Jetpack and see if that works? So far mine has in the past two days.

    It looks like adding in those Jetpack filters has done the trick for me. Thanks, Jeremy.

Viewing 15 replies - 16 through 30 (of 41 total)
  • The topic ‘Publicize Does Not Work’ is closed to new replies.