Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Publicise shares password protected entries despite unchecking the box.

  • Resolved lokiofsassgaard

    (@lokiofsassgaard)


    This only happens with password protected entries. I uncheck the boxes for both Tumblr and Twitter, post it, and the post is still shared to Twitter.

    Also, even if I want to share a password protected entry to Tumblr, for whatever reason, making sure the box is checked does not share the post to Tumblr.

    If the post is public, publicise works as intended. It’s only password protected entries. I use password protected entries as bonus content for my newsletter subscribers, so having these posts pop up on Twitter, only to immediately delete them gets pretty old.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter lokiofsassgaard

    (@lokiofsassgaard)

    Plugin Contributor Dan (a11n)

    (@drawmyface)

    Hi there

    We had a report of this a few years ago, but our developers were not able to reproduce it, and it hasn’t been reported since (until now).

    https://github.com/Automattic/jetpack/issues/7870

    I have also tested this on a brand new test site, and I’m unable to reproduce the issue, so it seems there may be something else on your site that is conflicting.

    The quickest way to figure out if something is interfering is to test for a theme or plugin conflict.

    I know it’s less than ideal, but could you please try the following:

    – Temporarily deactivate all the site’s plugins except for Jetpack and clear your browser’s cache.
    – Then test this issue again. If the post doesn’t get shared, then we’ll know that another plugin is conflicting here. You can re-enable your plugins one by one, testing in between, until you find the one causing the conflict. You can leave it disabled or reach out to the plugin developer for a fix.

    If disabling plugins doesn’t help, it may be the theme.

    – Temporarily switch your theme to a WordPress default theme like Twenty Twenty. Then test again. If the post doesn’t get shared, then you know it’s a problem with the theme, and you can reach out to the theme developer for a fix.

    Let us know how that goes.

    Thread Starter lokiofsassgaard

    (@lokiofsassgaard)

    Well luckily this didn’t take too long to suss out. When it didn’t happen on a “clean” install, and I could not even find the publicise settings on the new block editor, I had a hunch it might be the Classic Editor plugin. And it was.

    So I’ll reach out to them. And should anyone else come along in the future with this issue, that’s probably the likely culprit.

    I think that’s more annoying than the troubleshooting was.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Publicise shares password protected entries despite unchecking the box.’ is closed to new replies.