Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Publicise not working on scheduled posts but works on manual publish

  • Resolved ftwrthtx

    (@ftwrthtx)


    Publicize not working on scheduled posts but works on manual publish. If I manually publish an article, everything works fine, but scheduled posts publish, but nothing gets shared with publicize.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Support darnelldibbles

    (@darnelldibbles)

    Hi there,

    I see a few posts from yesterday that have now posted on your site.

    https://terminalgamer.com/2020/08/30/ghostrunner-receives-new-gameplay-trailer-key-art-at-gamescom/

    https://terminalgamer.com/2020/08/30/worlds-fastest-gamer-baldwin-claims-another-podium/

    Did you have to manually publish those posts or were you able to get scheduled posts working? If the former, please let me know if they were originally scheduled to post. I see that Facebook, Tumblr, Twitter, and LinkedIn are currently connected via Publicize. The posts did not show up on any of your accounts?

    Thread Starter ftwrthtx

    (@ftwrthtx)

    I manually published the world’s fastest gamer post and it worked fine but the ghostrunner post I had scheduled and it didn’t publicize at all so I had to manually add to facebook and twitter.

    Plugin Support KokkieH

    (@kokkieh)

    Yep, I can confirm the Ghostrunner post didn’t publicize.

    I see we haven’t done a full sync of your site for quite some time. If sync isn’t running on your site when it should, that could explain this.

    I’ve scheduled a full sync to run on your site. Let’s give that 24 hours to complete, then schedule a post and see if it publicizes. If not, let us know.

    In that case, also check the Site Health page in the dashboard and let me know if you see any errors there related to Jetpack Sync.

    Thread Starter ftwrthtx

    (@ftwrthtx)

    Thanks for your help. I’ll set an article to publish in the morning tomorrow.

    Thread Starter ftwrthtx

    (@ftwrthtx)

    Didn’t work.

    Plugin Support darnelldibbles

    (@darnelldibbles)

    Thanks for the update.

    What are you seeing when you visit Tools > Site Health? Let us know if there are any errors that you see related to Jetpack Sync.

    Thanks,

    Thread Starter ftwrthtx

    (@ftwrthtx)

    No problems with site health

    Plugin Support KokkieH

    (@kokkieh)

    What was that post that failed? The two most recent posts on your site, “Tony Hawk, Mike Pondsmith, AAA Panelists Delight Fans With Content Streaming 24 Hours a Day at First Ever PAX Online” and “Survival Horror Game Monstrum Gets a Physical Release Date”, published 23 hours ago, so before your comment above saying it didn’t work, both show as publicized in our logs for your site.

    Something else to check: Next time after you schedule a post, exit the editor. Then edit the post again and click the Jetpack icon in the editor. Do the Publicize options there still show as selected?

    Thread Starter ftwrthtx

    (@ftwrthtx)

    The BenQ post I scheduled and while it did publish yesterday morning, it didn’t publicize. I just scheduled a Mafia def. edition post and all of the checks were there for publicize when i exited and went back in.

    Thread Starter ftwrthtx

    (@ftwrthtx)

    and the Mafia post didn’t publicize. I had to manually tweet it and add to Facebook.

    Thread Starter ftwrthtx

    (@ftwrthtx)

    Any ideas how to fix this???

    I’m on the West Coast and would like to continue publishing articles before I get up in the morning. East Coasters already have half a day of news posted.

    Plugin Support KokkieH

    (@kokkieh)

    Okay, I did some digging, and sometimes this can be caused by caching on a site. Are you using any caching plugins?

    I notice your domain’s DNS is managed by Cloudflare, so are you perhaps using their caching services? Or does your hosting provider themselves have caching active?

    If your site is being cached at any of these levels, please check if disabling that caching helps at all.

    Thread Starter ftwrthtx

    (@ftwrthtx)

    I’ve been using cloudfare for a long time now. Never had an issue before. This has to be something with Jetpack iteself

    I have a question. Can you manually share posts via wordpress.com to social media

    Thread Starter ftwrthtx

    (@ftwrthtx)

    If I manually publish, everything gets publicized properly. It’s only scheduled posts that don’t publicize.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Publicise not working on scheduled posts but works on manual publish’ is closed to new replies.