Support » Plugin: amr users » Public view displays a long empty list

  • The site & plugin were working fine, last week we ran updates/upgrades for WP and other plugins and then the problems began.

    First we were getting PHP out of memory errors on the server and the page would display as if there were no cached data (the refresh button would appear). Being a VM with a lot of headroom I didn’t think it was much of an issue. Opened the max memory for php to 1024Gb, hit the ‘Rebuild cache in the background’ and waited.

    Now, the page displays the list as empty. The pagination is there, the lines between table cells are visible, but visually look like a blue block because all the cells are collapsed (for lack of data).

    Rebuilding the cache runs successfully. Every time I do, I can get the page to work for maybe a minute, then it reverts back to these blank rows.

    Any suggestions?

    EDIT: I just also noticed the pagination indicates there’s over 68k entries. My user list is about 18.5k.

    EDIT 2X: I also went into the db and looked at the cached table. It looks as though all the data is there.

    • This topic was modified 1 year, 3 months ago by  wisefool.
    • This topic was modified 1 year, 3 months ago by  wisefool.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author anmari

    (@anmari)

    Hi wisefool,

    Looks like you have a number of weird things happening.
    It briefly started working – pagination listed about 17K users & the user data was displayed – maybe you cleaned out crap data? paging through works, very fast, but any attempt to reduce ‘rows_perpage’ to say 2, causes a server error again. Then suddenly it’s back to thinking it has 68,432 users. I’ve never seen that before. Is there anything unusual about your data? any addons fetching data from other tables?

    Written earlier before I got a 17K user list:

    it looks like the server is struggling. I tried to reduce the perpage to 2 (ie just fetch 2 records from the cache table) and just kept getting 502 server errors.
    At that point all it is trying to do is read a subset from the table and display it. Consider reducing the perpage in the settings to say 10.

    The ‘no lines found’ message then appeared, probably because it was rebuilding the cache table. You have a high number of records. See note 1 on plugin front page https://wordpress.org/plugins/amr-users/ The plugin was never intended for high volumes, the way it is currently written.

    Then I get the cache update in progress message. This is clearly taking a very long time.

    Once it has a cache, it looks like it then has a problem pulling from the cache table (you said it looks like the data is there, so problem is in the server accessing it.) OR in formatting the row.
    The pagination info is stored in an option, so it is pulling that ok from the database and displaying that before it gets to the trying to fetch & display the user data. It is trying to list the rows, which it should only do if it did get some data, so I don’t know why it doesn’t return the html for the data. Are you using any custom add-ons? There is one to list the rows, Deactivate those to see what happens.

    I am not an expert in server setup or database. I would get someone to look at the system log, and the sql database and look for errors that might shed more light. See if you do a straight SQL select rows on the cache table, does that work?

    Also not a memory expert, did you increase wordpress memory limit (not just php?). I don’t think it’s a memory error – it feels more like a data extraction and cache storing error. Something weird about the data and database?

    In the interim, if it were my site, I’d also reduce the cache rebuild frequency – maybe only once a day.
    https://wpusersplugin.com/3458/cacheing-amr-users/

    Since it will be awhile before a non-cache based version of this plugin is released, I’d also look for an alternate solution – maybe a ‘lean’ custom solution as noted in note1.

    If you learn anything further, please do let me know as it would help if someone else ever reports similar behaviour.

    Plugin Author anmari

    (@anmari)

    Still playing with it, searching on text initially worked.
    Then all of a sudden, there 51,324 users, then search didn’t work.
    If the same code keeps giving different results, it has to be something else impacting it

    Plugin Author anmari

    (@anmari)

    Forced a refresh, server error, then the sql thinks it had 19,108 users.

    Plugin Author anmari

    (@anmari)

    I’m guess some SQL queries are taking too long and being aborted?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Public view displays a long empty list’ is closed to new replies.