Support » Plugin: Quantcast Choice » Public script requires jquery

  • The plugin enqueues this public javascript file:

    wp_enqueue_script( $this->plugin_name, plugin_dir_url( __FILE__ ) . 'js/script.min.js', array(), $this->version, true );

    Since this script requires jquery, it should be specified it is required like this:
    wp_enqueue_script( $this->plugin_name, plugin_dir_url( __FILE__ ) . 'js/script.min.js', array('jquery'), $this->version, true );

    Please fix it, because it breaks javascript optimizations (render blocking js in the footer).

    Thank you

  • The topic ‘Public script requires jquery’ is closed to new replies.