Support » Plugin: Kanban Boards for WordPress » public / everyone access not working

  • Hi Folks – have the Kanban:Pro 0.0.12 on WP 5.7 at SiteGround. On two different sites, diff themes, plugins, Public / Everyone access is no-go. The basic page HTML loads but the swim lanes. tasks, etc, do not. If I login from the partially loaded page. Then the display works as expected.

    But the anon/public/eveyone access is THE reason I updated to Pro.

    Help is appreciated. Thanks, Kirk

    • This topic was modified 6 months, 1 week ago by kgrier.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author gelform

    (@gelform)

    Hey, there!

    I just pushed an update to the Kanban core plugin here on the WordPress plugin repo that should fix the issue for you. Please update to version 2.5.17 and let me know if you still experience the issue!

    Thanks,

    Corey

    Thread Starter kgrier

    (@kgrier)

    Winner! Thank you for the quick response!

    Plugin Author gelform

    (@gelform)

    Great!

    Thread Starter kgrier

    (@kgrier)

    HI – I’m back – looks like the public view is not getting all update to the board. Is there some timer on refresh of that view? The actual board now has four tasks in the Archive column not showing in the public view.

    https://homage.bsh.zone/kanban/board?board_id=1

    Thread Starter kgrier

    (@kgrier)

    Not sure if this helps but I did a purge on the siteguard cache and a refresh of the board URL get’s all the tasks in the correct lanes.

    So let me see if I exclude ./kanban/* from caching to see if that addresses

    • This reply was modified 6 months, 1 week ago by kgrier.
    Thread Starter kgrier

    (@kgrier)

    Nope, SG confirms the URL is not cached now but changes to column tile or task placement are not reflected in public view, though they are in another logged in user view, until I purge the SG cache and refresh the public view page.

    How to address?

    Thread Starter kgrier

    (@kgrier)

    Disable / enabling NGINX does not alter, still need to clear SG cache, but clearing the dynamic cache is enough to allow the public view to be updated on refresh. Are there more URK’s to exclude from caching for the public view?

    Plugin Author gelform

    (@gelform)

    Hmm, all of the polling requests for updates are returning 400s (screenshot https://prnt.sc/10kkc6m ). Could you check your error log and see if that tells us what the issue is?

    Thread Starter kgrier

    (@kgrier)

    Not sure what I am looking for here. There is nothing in the error log except a missing index.html from much earlier in the day. Here is access.log showing my purge. Then a refresh. I disabled the SG caching and the issue still happens. Somehow the data is not being seen as changing on the public / anon user though it works just fine on a logged in account.

    Hmm, post got get to mod, prob cause looked like pers log data. let me find other way to share – I’ll submit through form in plugin.

    Plugin Author Keanan Koppenhaver

    (@kkoppenhaver)

    Hi Kirk,

    Just wanted to check in and see if you’re still having an issue here? Anything I can help you look into?

    Thread Starter kgrier

    (@kgrier)

    Hi – yes, still an issue, related to caching. If I disable the SiteGround Optimizer, the public view will update once, but it will not update further. If I then disable NGINX Direct Delivery, no update, but if flush the Dynamic Cache then I get an update, memcache is already disabled. This is their page on the Dynamic Cache. The only time I get a public view update is when I flush the dynamic cache.

    https://my.siteground.com/support/tutorials/supercacher/dynamic-cache/

    Thanks – Kirk

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.