Support » Plugin: JW Player for Flash & HTML5 Video » Pseudostreaming requests not made on seek

  • I setup h.264 streaming module in my apache server and requesting a video segment with start and end parameters works perfectly from curl on the command line.

    I added startparam=start (that is the correct query parameter for my apache module as it works from command line) and it is added to the embedded parameters for jwplayer.

    If I try to seek to a time in the video that is not downloaded yet, it does not send any request to the web server, how can I debug this?

    As I said the video is properly formatted as it works if I send a request from curl but jwplayer is just not sending the requests.

    Here is a link to an example page with links to the video as well

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author JW Player


    Try without the startparam and if that does not work try starttime or apstart.

    Thanks for the quick response.

    I did try starttime but as the curl requests show “start” is the correct parameter that is accepted by the server.

    The question is not, why is the server not sending the adjusted data back to the player, but why is the player not sending the requests containing the startparam to the server. The access logs show no requests with starttime are ever received.

    Plugin Author JW Player


    Are you sure the module is installed correctly?

    Plugin Author JW Player


    Also, what is the shortcode for this post?

    Yes the apache module is installed correctly. The curl commands show that it is responding to the start= query parameter when I request different start values for the video.

    The shortcode of the video in the test link


    jwplayer config=”Medium” mediaid=”204″

    I created a Medium config that has “startparam=start” and uses a default size I want for my videos.

    Again. If the player is working as expected, when I try to seek to a new part of the video with pseudostreaming enabled, it should send a request to the server with start=XXXX for the number of seconds to seek, correct? If this is the case, that is not happening. If not, then perhaps I misunderstand how this works.

    Thanks again,

    Plugin Author JW Player


    If you are using JW5, it should be something like:

    [jwplayer file=”something.mp4″ provider=”http” http.startparam=”startime”]


    [jwplayer file=”something.mp4″ provider=”http” http.startparam=”start”]

    Or just:

    [jwplayer file=”something.mp4″ provider=”http”]

    Thanks I’ll try that. How would I figure that out, is it documented? There is a setting in the configs for flashvars, and my previous searches only showed adding the startparam there, but I’ll try this!

    It worked! Thank you for this assistance.

    Plugin Author JW Player



    I setup h.264 streaming module in my apache server succesfully too.. but I didnt know where to add startparam or what i need to add ? Please help me . My problem is i cant skip time if video not load.

    Plugin Author JW Player


    Just add startparam=”start” to your shortcode.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Pseudostreaming requests not made on seek’ is closed to new replies.