Support » Plugin: WooCommerce Google Ads Conversion Tracking » PSA: This plugin now requires PHP 5.4+

  • Resolved Lucas Karpiuk

    (@karpstrucking)


    Just a heads up, in case you recently updated the plugin to version 1.4 and began seeing a fatal PHP error (below) or white screen of death (WSOD), check your PHP version. The plugin now requires PHP 5.4+ due to the use of anonymous functions. If you’re using PHP 5.3 (for some reason?), you need to roll back to version 1.3.6 of this plugin.

    Parse error: syntax error, unexpected '[' in wp-content/plugins/woocommerce-google-adwords-conversion-tracking-tag/wgact.php on line 364

    • This topic was modified 2 years, 4 months ago by Lucas Karpiuk. Reason: formatting
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author alekv

    (@alekv)

    Hi Lucas

    I just released a new version that will fix the issue. Usually I don’t uphold backward compatibility for PHP versions that have reached end-of-life. For PHP 5.4 that was mid 2015. But this was a 5 minutes easy fix to implement (thanks the log you provided).

    You might have to upload the plugin through FTP to get it to work again. Just overwrite the current folder.

    Regards
    Aleks

    Hey @alekv,

    I’m not sure why this particular site is still using PHP 5.3 (it’s not my own), but in any case I appreciate the update for back-compat – we were able to update to 1.4.1 without any issues.

    Thanks!

    Plugin Author alekv

    (@alekv)

    Thanks for the update!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PSA: This plugin now requires PHP 5.4+’ is closed to new replies.