Support » Fixing WordPress » Proper ‘hostname’ format?

  • hi,
    I am trying to install plugins (and update) via the admin panel and I am having trouble connecting. I am not sure what the proper syntax is.
    When I enter:

    Hostname:mysite.com
    Username:name
    Password:password

    and then I get this:

    “Error: There was an error connecting to the server, Please verify the settings are correct.”

    and the hostname has been replaced with this:

    Hostname: “mysite.com://www.mysite.com/”

    What is the correct syntax for entering my Hostname? Or am I making some other mistake?

    Thanks in advance!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Same for me. I’ve checked the forums and tried all the various answers for me and I get the same error code and the hostname does the same thing. I hope someone can help.

    The majority of the time, the host name for a MySQL database is “localhost“, with the exception of a few hosting companies (like GoDaddy, they have one that look like pXxl4XmysqXX.secureserver.net).

    1and1.com has similar hostnames as godaddy.com

    When I setup my DB it gave me the proper info to put in…

    I am on network solutions and figured out after hours today the proper hostname…hope this helps somebody…Under the FTP User Accounts there is your FTP account name…I just copied that and added http:// before all the numbers and I think…now I don’t remember added .com at the end. And tah-dah! It worked.

    One other thing I did on network solutions BEFORE I tried this was reset file permissions and needed to wait about 10 minutes before it worked…I really don’t know what much of that means but it may help someone.

    Peace
    Janey

    I have the exact same problem. No matter WHAT i put into the hostname field, it automatically resets itself to “mysite.com://www.mysite.com/” Not quite figuring this one out. I thought at first that it was a browser issue, but this hostname is being stored somewhere within the wordpress software…

    This question should properly be directed to your hosts support people. I also use 1and1, and this information is prominently displayed on my control panel with the SQL information.

    Host support is there for your use. Use it.

    OK, the hostname is being stored in the database in an option called “ftp_credentials”

    for instance mine reads

    a:5:{s:8:"hostname";s:20:"www.isaac-online.com";
    s:8:"username";s:10:"thenothing";
    s:3:"ssl";
    s:1:"0";
    s:15:"connection_type";
    s:3:"ftp";
    s:4:"port";
    s:22:"//www.isaac-online.com";}

    so when we’re trying to do the automatic update, it’s pulling the hostname as http://www.isaac-online.com://www.isaac-online.com I’m assuming that the “//www.isaac-online.com” part wants to read 22, but I start pulling errors if I change that part.

    After trying to mess with things over and over, i ended up deleting the whole row. That cleared everything up and I was able to run automatic updates without an issue

    Hi. I had the same experience that Janey had. Thanks, Janey! I reset my file permissions. It didn’t take long to activate. For hostname I pulled from the FTP account manager as Janey did – and yes, include the .com. My username was pulled from the FTP user account listed on this same page. The password was the one supplied next to this FTP user account number – it’s the one that includes the % if you’re on Network Solutions.

    I think resetting the file permissions is key. The exact same steps did not work, until I reset the permissions. Then it was seamless. PS I work on a mac.

    pleas help me i have problem showing below error ,i write host name like this http://www.hotopics.co.cc

    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can’t contact the database server at http://www.hotopics.co.cc. This could mean your host’s database server is down.

    * Are you sure you have the correct username and password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Proper ‘hostname’ format?’ is closed to new replies.