Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » Prolem with Elementor & Google Maps

  • Resolved chill4

    (@chill4)


    Dear Complianz-Team!

    I am very happy with Complianz but I am not a programmer. I am also using WPML (if that info is important). My page is built with Elementor Pro.

    My problems:

    • I cannot see a placeholder for the Google Map.
    • If I “ACCEPT” all cookies, the Map also does not appear in Chrome.

    I really need this to work, please, and I am grateful for your help.

    Thank you,

    Andrej!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Contributor jarnovos

    (@jarnovos)

    Hi @chill4,

    Could you start by disabling the Advanced Custom Fields integration under Complianz > Integrations > Plugins, to see how the behavior changes after doing so?

    In addition, could you let us know what plugin you’re using to place the Map?

    Kind regards, Jarno

    Thread Starter chill4

    (@chill4)

    Hello jarnovos!

    Thank you for taking care of my problem!

    • I disabled the integration (not knowing what that means), but it does not seem to change anything. The map is shown in Chrome whether I accept or deny.
    • In order to achieve the coloring and multiple pins, I used the “Advanced Maps” widget from JetElements (Crocobloc).

    I am looking forward to get this sorted out, I really need this… Thank you!

    • This reply was modified 12 months ago by chill4.
    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @chill4,

    Disabling the integration caused the Map to be restored in its original “unblocked” state, so that it doesn’t disappear anymore.

    The actual issue though, whereby the Map isn’t currently being blocked with a placeholder, occurs because there is currently no integration with the “Advanced Maps” from JetElements yet.

    As we don’t currently have the JetElements plugin to create and test an integration, I have created a Feature Request for this integration. https://complianz.io/feature-requests/integration-with-advanced-map-widget-jetelements-crocoblock/

    So, the integration will be considered for a future release of the plugin. We’ll reach out to the developers of this plugin to obtain a development license for testing purposes.

    Kind regards, Jarno

    Thread Starter chill4

    (@chill4)

    Dear Jarno,

    would you mind telling me how I can fix this in the mean time? The page has to go online and I please need some compromise. May I switch some things so the Google Map will appear despite “accept” or “deny”?

    Thank you so much!

    Andrej

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @chill4,

    It should already be working regardless of Accept/Deny with the current configuration, and if I visit your page in a fresh Incognito window in my browser it appears to work fine at the moment.

    Are you still experiencing any issues?

    Kind regards, Jarno

    Thread Starter chill4

    (@chill4)

    Dear Jarnovos!

    Thanks again for being so quick! I tested things now:

    • EDGE: Map does not appear. upon first visit while ignoring the banner. On “accept” and reload, it does not appear. I cannot make the map appear in EDGE in both languages.
    • CHROME: Map does not appear on first visit when ignoring the banner. Upon accept, Map appears. Upon “deny” map is not shown, no placeholder. If I switch back to “accept”, map does not appear.
    • FIREFOX: Map does not appear on first visit when ignoring the banner. Upon accept, Map appears. Switching back and forth between “allow” and “deny” works fine.

    Look, this is just the kind of behavior my boss hates. Do you please have a solution where the map is always displayed, even if the visitor is ignoring the banner for the time being?

    Thank you very much,

    Andrej

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @chill4,

    As long as the Google Maps and Advanced Custom Fields integrations are de-activated under Complianz > Integrations, Complianz will no longer block or affect this Google Map on your website.

    This was the case previously when you disabled the Advanced Custom Fields integration, but it seems that it has now been enabled once more; therefore causing the “disappearing map” behavior to return as well.

    Thread Starter chill4

    (@chill4)

    Dear Jarno,

    thank you, that seems to work. Do you have an idea how long it may take until Crocoblock is integrated? I think it is not that uncommon?

    Thanks again,

    Andrej

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @chill4,

    Here is an integration to block the JetElements Advanced Map, you can add it as an MU Plugin. You can see my example page here: https://jet-elmnts.instawp.xyz/map/

    Upload the attached file as a .php file in the folder /wp-content/mu-plugins/. Make sure you also have the Google Maps integration enabled under Complianz > Integrations > Services.

    jetelements-advanced-map.php

    Kind regards, Jarno

    Thread Starter chill4

    (@chill4)

    Dear Jarno,

    I managed to install the file and the placeholder is appearing! Wow, thank you! If I click “accept” on the placeholder, the map does not appear? What am I doing wrong?

    If I click “accept” on the placeholder AND the banner, THEN the map appears. I don’t think this is meant this way.

    Thank you very much,

    Andrej!

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @chill4,

    Can you try it without Consent per Service enabled, by answering “Do you want to use Consent per Service?” with No under Complianz > Wizard > Consent > Services?

    Kind regards, Jarno

    Thread Starter chill4

    (@chill4)

    Dear Jarno,

    I am sorry I took so long, I had to do a few tests in order to give a proper report and understand the problems myself.

    Please let me assure you I read the documentation and watched all YouTube tutorials I could find to answer every question for myself as far as I could.

    I Installed the MU plugin you provided. Now what?

    • I tested everything with Chrome, no caching or accelerating plugins are activated.
    • The placeholder is appearing now, but it is a rather ugly image and the button also looks bad. How may I change the appearance of that placeholder to look like my template? Under “Placeholder style” I am unable to choose anything different than “default”, all else is greyed out. I created the folder within my template folder and inserted an Image, it does not show. If I switch the “Placeholder ratio” to Custom, an empty placeholder (the grey mountain) is showing up.
    • If I click “I agree”, the Google map does not appear. Only if I later click “accept” in the banner also, the Map appears. So, I have to “accept” twice, on placeholder and banner. I don’t think that’s right. This improves once I deactivate “Do you want to use ‘Consent per Service?’. But then, I still have all the options like “preferences” and “statistics” in the banner.
    • If I enable “Consent per Service”, I still just get “preferences” and “statistics” in the banner. Should it not say “Google Maps”, “WhatsApp” and so on? I don’t understand how this works. SORRY. Does this “Service descriptions” section only here to create the cookie policy or can these services be listed and toggled on and off inside the Banner?
    • There is another grave problem: As long as I dont “accept”, not only is the Google Map not showing, but the animated charts done with Crocobloc are also not shown! Parts of the site become broken or unlocigal (success percentage remaining at zero because the animation is blocked, for example here: https://whitestonecapital.us/real-estate-investment-sunbelt/). All charts are missing although they are not GDPR relevant. Even if I hit “accept”, I have to hit Ctrl+R two times until the graphs are showing up again. This is scaring me.
    • The text inside the placeholder also makes no sense. How do I translate it and the “privacy policy” link?
    • If I do not click “accept” on the placeholder but only on the banner, the map is also appearing, that seems to be right.

    In the meantime, other problems/questions came up:

    • Analytics: If I visit the start page and click “accept”, the visit to the startpage is not counted. Analytics only counts all pages visited thereafter. Should the page not reload to be counted properly or is there another way to make this start page visit count?
    • Sometimes, if I click accept on the map and the banner, the map still does not appear until I hit Ctrl+R. This seems all pretty unreliable to me. I do not dare showing ths to my client.
    • In the banner itself, there is a link “Manage services” which does nothing but opening my “privacy Policy” page. What is that for? The links are already below the buttons?

    I am really grateful for your help. Honestly, after weeks with Elementor and WPML, these Complianz-Issues are torturing me. I am not a programmer and not familiar with CSS.

    Although the page is basically done but I cannot deliver because I am trying to understand this erratic behavior. Please have mercy with me. I would happily hand over login credentials.

    Thank you so much for supporting me! I am not really a technical noob, but I find this all pretty confusing. I am totally willing to go pro once this is all settled.

    Thank you so very much!

    Andrej

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @chill4,

    Maps & other elements on the page

    Allow me to clarify why this works the way it does. The provided integration blocks a script called “jet-elements.min.js” which contains the JetElements Google Map code; but also code for their other elements. As we can’t isolate the Map code specifically and when we block this script, the other JetPlugins elements are also blocked as a result.

    For a more ‘specific’ integration, an integration from the JetElements side of things would probably be the best solution (i.e. only load the Maps API if Complianz has consent), so we wouldn’t need to block this script entirely.

    In any case, I have made some adjustments so that it should work with Consent per Service: jetelements-advanced-map.php

    But that’s about as much as I can do here. If the result is not satisfactory; you can always remove the MU Plugin to restore the Map to its original state, which will also stop affecting other JetElements items on the page.

    Placeholder styles greyed out

    This option is greyed out as these other Placeholder styles can be enabled in the Premium version of the plugin.

    Blocked content text

    Can be changed under Complianz > Settings > General > “Blocked content text”.

    Consent per Service & Manage Services

    Consent per Service won’t change the categories on your banner, but allows you to granularly consent to one individual service, i.e. by clicking the Google Maps placeholder; and the Marketing category would still be disabled.

    With Consent per Service enabled, this Manage Services link will point to your Cookie Policy which, if generated by Complianz, contains the list of cookies/services and where users can revoke consent per individual service.

    Kind regards, Jarno

    Thread Starter chill4

    (@chill4)

    Dear Jarno,

    thank you so much for your quick and extensive response. I have decided that this is too much trouble for the time being. I have to get this webpage launched into the market and will have to fix this JetElements issue at a later time with PRO.

    I would like to have the Google map enabled regardless of acceptance.

    I disabled the integration and I took away the MU plugin. Now, the map still does not show up while the animations are working. If I hit “accept” AND reload, the map shows up.

    1. How may I achieve to have the map shown regardless of the banner? I would want ComplianZ not to interfere with this map, please. If I turn off the off the Google Maps integration under “Integrations/Services”, it does not appear. If I turn off the integration under “Integrations/Services”, click “accept” in the banner and reload manually, the map appears in Firefox, but not in Chrome. Same behaviour If I turn off the Google Maps integration under “Integrations/Services”.
    2. There is still my question about Analytics: If I visit the start page and click “accept”, the visit to the startpage is not counted. Analytics only counts all pages visited thereafter. Should the page not reload to be counted properly or is there another way to make this start page visit count?

    I seem to have a general problem understanding the logic. Up to this point “accept” means “The page will no longer be broken from now on” but not “okay, let me reload, count and show you the good stuff”. Can you please explain how this works?

    Thank you,

    Andrej

    • This reply was modified 11 months, 3 weeks ago by chill4.
    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @chill4,

    You have one other integration enabled that affects the Map, if you disable the Advanced Custom Fields integration under Complianz > Integrations > Plugins, the Map should no longer be affected.

    I have taken a look at the Analytics script as well, but it seems that Complianz correctly loads it after consent is provided. The Analytics pageview is being triggered without a reload. I’ve recorded a short video where you can see this.

    Kind regards, Jarno

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Prolem with Elementor & Google Maps’ is closed to new replies.