Projects don't work after domain changed (5 posts)

  1. fjah
    Posted 1 year ago #

    My "Project" pages appear perfectly on my homepage, but when I click on them they lead to "Page Not Found."

    This problem was previously posted here but it looks like they never got an answer.

    I'm afraid this might have something to do with some recent changes to my website domain name.

  2. ellp
    Posted 1 year ago #

    Hello Fjah!

    Did you re-save your permalinks?

  3. fjah
    Posted 1 year ago #

    Thanks ellp.
    Yes, I've re-saved my permalinks but the problem persists. This permalink problem is weird because it only affects my project pages but nothing else...

  4. ellp
    Posted 1 year ago #

    Hello again!

    I think is a good idea to check your database for old url entries. Check this article:


    Database is not my strongest point you know, but I hope it helps you to start to solve your problem.


  5. fjah
    Posted 1 year ago #

    Hmm, I couldn't find any old URLs.

    Good news through. I switched my permalinks setting back to default (aka ugly) and all the projects pages now work! I don't know why. I looked through the directory and database but it's hard to see the path because there is no "projects" folder.
    All I know is that the default permalink [http://example.com/?project=project1] works perfectly but the post name permalink [http://example.com/project/project1/] leads to "Page Not Found."

    Is there a way to make the permalinks just for the projects be on the default setting but all the other permalinks be on the post name setting?

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic