Support » Plugin: AudioIgniter » Progress bar and countdown timer don’t work straight away

  • Resolved menathor

    (@menathor)


    Hi guys,

    First of all, fantastic looking plugin. However I’ve noticed that when streaming a song, clicking on the progress bar just re-starts the song from the beginning. Also clicking the time to switch to it to countdown (remaining time) doesn’t work. It just displays -0:00. If I let the song complete, I can then use the progress bar to skip within the track and the time remaining counter works. However as soon as I click another song, then go back to the first one, the same issue happens again.

    Any ideas on how to solve this? The audio files are MP3s. Tested on both Chrome and Firfox, latest versions.

    • This topic was modified 3 years, 2 months ago by menathor.
Viewing 4 replies - 1 through 4 (of 4 total)
  • I’ve just discovered it works perfectly when the MP3s are hosted on a different (external) server to my web server. Any reason why it would work when streamed from another server?

    Plugin Author Vassilis Mastorostergios

    (@silencerius)

    Hiya, thanks for the kind words ๐Ÿ™‚

    Yes this is an issue with how the server is configured to serve media files and it’s not plugin specific (for example the same behaviour would happen with WordPress’s default player — if it doesn’t let us know).

    I’m afraid I don’t have an out of the box solution for you on this as it could be a number of different things with either how the server is configured or your WordPress installation, I would start by comparing the response HTTP headers of each mp3 coming from both sources, seeing if there are any difference that might give a hint.

    I also found this link http://blog.pearce.org.nz/2009/08/configuring-web-servers-for-html5-ogg.html where it talks about OGG but could help for other media types as well.

    If you have any luck please get back to us with your findings if it’s not a hassle, and apologies I can’t be of much help ๐Ÿ™

    Thanks for the information! That link was quite useful. It seems Apache is unable to serve the necessary headers for streaming if gzip is enabled. By switching gzip from “compress all content” to “compress specified MIME types” and specifying just txt, javascript etc. I was able to get it working.

    Plugin Author Vassilis Mastorostergios

    (@silencerius)

    That’s awesome, glad you could work it out!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Progress bar and countdown timer don’t work straight away’ is closed to new replies.