• Hello,
    I am redesigning a site on a temporary URL. I have the old site live at the moment. I have a membership directory on my site in development that you can get to at
    http://162.214.20.234/~cwporg/Oldsite/members-2/

    When I click the name of the person in the directory to get to their profile I get a 404 error. I have a page set up called User with the following form ID that I set up for profiles. [ultimatemember form_id=7606] Not sure why I am getting the error as the current site has the exact same settings and is working fine.

    Any thoughts? Is there any way to disable the link on the name to the profile?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • I think you are mixing uppercase/lowercase, that’s why it doesn’t work. If I type http://162.214.20.234/~cwporg/Oldsite/user/sarah/ I do see the user profile.

    On your second remark, I’m looking for exactly the same thing: disable the links on the member list profiles. Anybody done that already?

    Kind regards,

    Joris.

    Thread Starter lynxrufusboo

    (@lynxrufusboo)

    Can you elaborate by what you mean by “mixing uppercase/lowercase” and how do I fix it? I don’t know why Ultimate Member changes /Oldsite/ to /oldsite/.
    Thanks so much!

    • This reply was modified 4 years, 10 months ago by lynxrufusboo.
    • This reply was modified 4 years, 10 months ago by lynxrufusboo.

    I saw in your URI of the “Oldsite” that you have an “O” uppercase but the link to ie. Sarah’s profile is in lowercase and brings to the 404 error. When I change it manually back to uppercase “O” her profile pop’s up. You might a rewrite rule somewhere doing it. Rather then spending time on searching that, I would advise to use lowercase only for your URI’s. Even though “old-fashioned” this still remains best practice.

    Thread Starter lynxrufusboo

    (@lynxrufusboo)

    Thank you for your reply. I understand that is best practice but my site was put in a subdirectory with the name /Oldsite/. For some reason Ultimate Member understands that for the Member directory form but it changes it for the Profiles. You can see the URL change when you click the person’s name. Do you know where in UM that is controlled? It shouldn’t change it.

    I’m looking myself for that part as well, namely to be able to disable them. I have done so by disabling the links in /templates/members-grid.php but that is not a sustainable solution since it would be overridden in the next update. It could help for the time being though…

    J.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Profile Links not working’ is closed to new replies.