Support » Plugin: Bio Links » Profile image does not show up

  • Resolved anjapepunkt

    (@anjapepunkt)


    Hi, I’ve been using the plugin for a couple of months and recently my profile image doesn’t show up anymore. It’s visible in the preview page but not on the actual page. Any idea what might be causing this issue? It did work at the beginning…

    Thanks,
    Anja

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • joomapp

    (@joomapp)

    Hi Anja,

    Same problem here. It appears that the auto added srcset=”” by wordpress is the issue. Once I remove that from the source through firebug it works.

    As a workaround i have set the logo hardcoded in the following file:

    /httpdocs/wp-content/plugins/bio-links/public/templates/default/content.php

    Remove: <?php biolinks_current_meta()->the_thumbnail() ?>
    And then insert your logo path, like:

    < img src=”https://www.website.com/wp-content/uploads/2020/02/Asset-8-min-150×150.png&#8221; alt=”PWA logo” width=”150″ height=”150″ />

    But i have no idea how to change it dynamically 🙂

    Jasper

    • This reply was modified 1 year ago by joomapp.
    • This reply was modified 1 year ago by joomapp.
    • This reply was modified 1 year ago by joomapp.
    Thread Starter anjapepunkt

    (@anjapepunkt)

    Hi Jasper, good to know it’s not just me. I just have no idea how to do what you mentioned 😀
    Thank you though!
    Anja

    joomapp

    (@joomapp)

    I edited the reply with instructions

    Thread Starter anjapepunkt

    (@anjapepunkt)

    Amazing, thanks. I’ll have a go at this later! 🙂

    Thread Starter anjapepunkt

    (@anjapepunkt)

    Sadly didn’t work for me. The URL for the image file is being read wrong as this: https://www.mywebsite/links/anjap/%E2%80%9Dhttps://www.mywebsite.com/wp-content/uploads/2020/03/20190819_anja_1500.jpg%22 – So basically it adds the URL of the page in front of the location for the image.

    Thanks for the suggestion though 🙂

    joomapp

    (@joomapp)

    Hi,

    This cannot go wrong when you remove the line:
    “<?php biolinks_current_meta()->the_thumbnail() ?>”

    and inserts the absolute path to your image (like mine, but without the space after the first < next to img tag)

    It’s hardcoded in the file then.

    Jasper

    Plugin Author pyronaur

    (@pyronaur)

    @anjapepunkt Hi – sorry I’m a bit late to the party. I don’t see the issue in the URL you provided.

    I’m not sure why WordPress srcset would produce this issue, can you set the link back up so that I can have a closer look?

    Thread Starter anjapepunkt

    (@anjapepunkt)

    @pyronaur I tried fixing it a couple times and then gave up. Sadly had to switch to a different plugin as it just would not display my photo… The link in my original post does not work anymore.

    Plugin Author pyronaur

    (@pyronaur)

    Uhh. Well if you ever decide to give this another shot – let me know and I can look into the issue 🙂

    Thread Starter anjapepunkt

    (@anjapepunkt)

    Thank you 🙂

    joomapp

    (@joomapp)

    @pyronaur hi there, same issue for me. I can give you access/ view if you want. You can contact me directly with my avatar name info in front and com behind.

    Plugin Author pyronaur

    (@pyronaur)

    You can post a link to your site here – I don’t need any special access 🙂

    joomapp

    (@joomapp)

    Hi there,

    Sorry to have keep you waited; here a fresh install (09.04.2020) with bio links on WP 5.4. If you firebug into the page source code and remove the URL from srcset and data-srcset the image is shown.

    https://www.jeroenrietvelt.nl/links/bio/

    Jasper

    • This reply was modified 1 year ago by joomapp.
    Plugin Author pyronaur

    (@pyronaur)

    Hi Jesper,
    Looks like there’s some SVG embedded within that image:

    
    data:image/svg+xml,%3Csvg%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%20width%3D%27512%27%20height%3D%27491%27%20viewBox%3D%270%200%20512%20491%27%3E%3Crect%20width%3D%27512%27%20height%3D%273491%27%20fill-opacity%3D%220%22%2F%3E%3C%2Fsvg%3E
    

    Is this a PNG file or an SVG file you’re trying to use?

    Or perhaps – maybe your Cache/CDN plugin is modifying images on the fly to optimize the site and add lazy loading?

    Either way – it seems that the image isn’t rendered because something is modifying the image on the fly. The plugin you’re using would work on most WordPress pages, but because I’m intentionally not running any hooks that would allow plugins to add more JS than necessary – lazy loading doesn’t work here, and so your image isn’t visible.

    I’d recommend looking into how you can disable whatever optimizations you have in place on Bio-links pages. Caching the HTML would be a good idea, but any other minifiers/lazy-loading things aren’t necessary as the plugin is already optimized.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Profile image does not show up’ is closed to new replies.