WordPress.org

Support

Support » Plugins and Hacks » Ultimate Member » Profile and cover photo not changing when jetpack is activated

Profile and cover photo not changing when jetpack is activated

Viewing 4 replies - 1 through 4 (of 4 total)
  • Tiger

    @azizul-karim-aec

    Finally i find that, this is happening for jetpack Photon module. Please, help me to escape from the problem !

    Tiger

    @azizul-karim-aec

    No response from ultimate member!
    I don’t want to deactivate photon module. So, please help!

    Plugin Author Ultimate Member

    @ultimatemember

    Hi Tiger,

    We don’t provide support over weekend which is why we have not responded yet.

    I am afraid that Photon and Ultimate Member do not work together at the moment as Photon is a CDN so it storing the profile/cover photo images and not allowing them to be changed.

    I have not used Photon before but you will need to exclude UM uploads from being cached by Photon. Maybe check the Photon documentation to see if it includes any information on excluding particular uploads.

    Thanks!

    you should change your naming scheme to include the original filename, such as coverimage_FILENAME.ext that way, a user would be “cache busting” by changing the image name, per the Jetpack Photon documentation.

    As it stands, with the name ALWAYS being “cover_photo-???.jpg”, the Ultimate Member plugin is running afoul of Photon’s “Cached forever” design.

    Turning Photon off and back on, doesn’t clear the cache and according to the docs online, nothing will except changing the file name.

    (FWIW I’m disabling Photon, I like many of JetPack’s features, but this “we keep it forever” approach offends my sensibilities no end, as does the fact that you are opted in for other’s storing your images by simply saying yes to “enable default features” when you activate the plugin with NO notification.)

    • This reply was modified 2 months, 1 week ago by  Ted Thompson.
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Skip to toolbar