Support » Plugin: Bol.com Partner Program Plugin » Produktlink doesn't work

  • Resolved Glszn

    (@projectfms)


    Hallo,

    I’ve updated the new bol.com version, but still it doesn’t work. I have a https site.
    WP version: 4.0.
    plugin version: 1.3.2.
    Theme: Made
    Link Site
    Activated plugins:
    Admin Menu Editor
    bbPress
    Bol.com partner plugin for WordPress
    BuddyPress
    BuddyPress Security Check
    BuddyPress Template Pack
    CF Whiteboard
    Cookie Notice
    iFlyChat
    Shareaholic | share buttons, analytics, related content
    The Countdown Pro
    Tick It
    Watu
    WP Mailchimp Subscription

    https://wordpress.org/plugins/bolcom-partnerprogramma-wordpress-plugin/

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Jordy de Ruijter

    (@jordy-de-ruijter)

    Hi ProjectFMS,

    What exactly doesn’t work?
    The products don’t show on your website or you can’t add the links at all?
    In the first case, could you provide me with a link to a page on your website where you added a productlink?

    Greetings,
    Jordy de Ruijter

    Hallo Jordy,

    I can’t add the links at all. When I insert the produktlink I get a blank page.

    Best regards

    Plugin Author Jordy de Ruijter

    (@jordy-de-ruijter)

    First of all I would like to make you aware of the face that AdBlock might be causing this problem. In case you are using AdBlock, please turn it off.

    If this is not the case, could you provide me with some screenshots of what is exactly happening when you try to add a productlink?

    You can also mail these screenshots to: jderuijter@netvlies.net

    Greetings,
    Jordy de Ruijter

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    You can also post screenshots on this thread by linking to them using a tool like http://snag.gy/

    Hai, I have no adblock. Here is the Link to screenshot. I hope it works.

    Plugin Author Jordy de Ruijter

    (@jordy-de-ruijter)

    So far I haven’t seen anyone with this problem, so it is difficult to say what is causing the problem.
    Could you check the console for errors when you open the popup? (F12 > Console)
    Besides that, could you try turning off the other plugins?

    I’ve turned the plugins on and off and the conclusion is that the plugins below – which are very important for my blog – are causing the problems. How to solve this and what must I do with the information in the console?

    Plugins causing problem with bol.com plugin:
    bbPress
    BuddyPress
    rtMedia for WordPress, BuddyPress and bbPress
    Shareaholic | share buttons, analytics, related content
    The Countdown Pro
    Spider Event Calendar

    Plugin Author Jordy de Ruijter

    (@jordy-de-ruijter)

    If the problem is caused by one of the other plugins I am afraid I can not help you any further. You might want to contact one of the developers of the plugin that is causing the problem and send them the information in your console. They will probably be able to help you.

    Greetings,
    Jordy de Ruijter

    I’ve contacted bbpress and they said “you would need to contact the plugin author about resolving the issue with the bbPress plugin”

    Now I’m back with you.

    I’ve also contacted buddypress and they say this, “

    but frankly if one states a number of plugins appear to cause an issue on an individual basis then the one common denominator would likely be the problem and in this case that’s the bol.com plugin, but that’s not pointing the finger so to speak at bol but the resolution will lie with bol rather than bbPress or BuddyPress.

    This is the whole reply:

    At this stage we can’t help as you provide no idea of what sort of issue you are having; this plugin author you contacted replied to you thusly You might want to contact one of the developers of the plugin that is causing the problem and send them the information in your console no information though!

    Not sure why you have arrived at the conclusion BuddyPress is the issue here though, BP is coded very tightly to WP standards and is less a plugin and more an extension of WP functionality.

    You actually list a number of fairly complex plugins that you consider cause the issue and seem to have posted this question on bbPress forum their response is going to be the same as ours at this stage without much more information, but frankly if one states a number of plugins appear to cause an issue on an individual basis then the one common denominator would likely be the problem and in this case that’s the bol.com plugin, but that’s not pointing the finger so to speak at bol but the resolution will lie with bol rather than bbPress or BuddyPress.

    @projectfms please don’t just copy other post responses lock stock and barrel take some responsibility for your predicament, you have been asked to provide details other than a simple screen capture which for developers isn’t going to be a whole heap of help.

    Please attempt to describe exactly what your actions are that are failing, attempt to provide any error messages seen in your browser console as has been asked.

    @jordy-de-ruijter Sorry if I/we appear to be throwing things back your way but BP & bbP run quite happily and do with one of the other plugins mentioned rt media. as the SC appears to show a modal window I’m going to guess the issue lies somewhere in the realm of JS but that’s as far as I’m going to be guessing 🙂

    @hugo, don’t come here and tell me what to do. Because of my english I choose to copy and paste your answer. I’ve already provided the nessesary steps and errors, so don’t come here and tell me I don’t take responsibility. This year I’ve posted a lot of posts about this issue. So please don’t email me about this anymore! If the issue isn’t with your plugin then this is not the place for you to be.

    Plugin Author Jordy de Ruijter

    (@jordy-de-ruijter)

    Dear Hugo and ProjectFMS,

    Whether or not the problem is caused by the Bol Partner Program Plugin or any other plugin, my goal is to help you solving the problem as far as I can. As Hugo says, I need to know exactly what you have done trying to solve this problem and what errors are being thrown up.

    Problems like these are mostly caused by JS errors indeed, but it’s a matter of searching for the source of these errors.

    Because of the fact that ProjectFMS told me the Bol Plugin worked after turning off the other plugins, I assumed the other plugins were throwing JS errors. This could be causing JS to stop executing further scripts, like the Bol plugin (this has been the case in other forum posts in the past).

    Finally I want to inform you of the fact that we are moving this forum to our own forum. We are providing Dutch support here. Could you please make a new thread there so we can continue this thread there?:
    https://developers.bol.com/forum/partnerprogramma-wordpress-plugin/

    Greetings,
    Jordy de Ruijter

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Produktlink doesn't work’ is closed to new replies.