WordPress.org

Forums

WooCommerce - excelling eCommerce
[resolved] Products per Page (12 posts)

  1. jvino
    Member
    Posted 2 years ago #

    I have searched and tried all the recommendations that I can find but for the life of me cannot get more than 5 items to display per page. I would love to show 20 per page. 4 columns 5 rows would be awesome.

    My site is:

    http://www.nwtacklesolutions.com

    I am using the Lucid theme from Elegant Themes if that helps.

    Thanks!!

    http://wordpress.org/extend/plugins/woocommerce/

  2. Roy Ho
    Member
    Posted 2 years ago #

  3. jvino
    Member
    Posted 2 years ago #

    Yes, I added that code to the end of the functions.php file and it still displays only 5 products. Any other idea??

  4. Roy Ho
    Member
    Posted 2 years ago #

    Then I suggest you ask your theme developer as different themes have their own ways of setting this...

  5. jvino
    Member
    Posted 2 years ago #

    They claim that it's the responsibility of the plugin provider. Any other idea??

  6. Roy Ho
    Member
    Posted 2 years ago #

    Well why not test their theory. Switch to 2012 default theme and put that snippet of code in the functions.php and see if it works...

  7. jvino
    Member
    Posted 2 years ago #

    Well that showed the items without adding the code. Since they won't really help out, and idea where the setting might be buried?? I'm a relative newbie.

  8. jvino
    Member
    Posted 2 years ago #

    Found it. Under Theme Options, General Settings, General, Number of Posts on Archive Pages,

    Changed to 20 and it displays correctly. Hopefully this will help someone else that is using Lucid or maybe another theme from ET.

  9. Roy Ho
    Member
    Posted 2 years ago #

    There is another setting but this isn't really the proper place to set it as it is actually for the blog posts. But if you're not using a blog on your site, it doesn't matter.

    If you go to settings->reading you will see an option of "Blog pages show at most" and you can try setting that to something else.

    Again that is a workaround. A proper WooCommerce compatible theme should not have to do it this way. This setting is ONLY suppose to be for blog posts.

  10. Roy Ho
    Member
    Posted 2 years ago #

    The method mentioned above will affect your blog posts as well...

  11. jvino
    Member
    Posted 2 years ago #

    See above.

  12. Forest Skills
    Member
    Posted 2 years ago #

    Thanks!! Just resolved the same problem that jvino reported.

    :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags