Support » Plugin: Facebook for WooCommerce » Products not showing on shop tab

  • Hello, I have installed and setup the plugin (1.10.2) following all guidelines without issues. I can see the products on the Facebook catalog, but they are not showing on the shop tab under the page I have selected.

    I have discovered that the catalog and pixel created by the plugin on setup, are under the personal business manager. This is correct?

    Any ideas?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author SkyVerge

    (@skyverge)

    Hey @danidub,

    There are a few reasons why the products may not be displayed on your shop page if they have made it to your catalog. If you’ve only just configured the plugin, the most likely cause is that Facebook is still processing the newly added products. This can take up to 24 hours sometimes, so it would definitely be worth waiting a bit longer to see if they start appearing!

    If we still don’t see any products on the shop page later today, or tomorrow morning, we can dig in a bit further. Each product will have a visibility setting that can be controlled from WooCommerce, so it would be worth checking that these are set to be shown. We can check this from the Facebook catalog too.

    Virtual products are another common cause for this issue, as Facebook does not allow virtual products under their commerce policy. This means that all virtual products will be set to hidden by default.

    Finally, the pixel and catalog that the plugin creates will use the account you were currently logged in with at the time of running the connection wizard. Alternatively, it will ask you to login with an account that has access to the shop page instead. The connection wizard currently only supports Ad Account pixels, rather than Business Manager pixels though, so I think even if the catalog has been created under Business Manager it’s probably not a problem if you were able to complete the setup!

    That said, I’d be interested to hear how you get on Daniel. Could you let me know if you’re still having issues later today or tomorrow morning?

    Cheers!

    Simon.

    Hi @skyverge, great to hear from you.

    I have checked visibility on WooCommerce and they are all visible and not virtual products. So I think this would be Facebook processing products.

    I’ll update this ticket tomorrow.
    Thank you.

    Plugin Author SkyVerge

    (@skyverge)

    Hey @danidub,

    Ah, that’s great. Thanks so much for confirming! There is one other issue I forgot to mention, if the product catalog is not linked to the shop page correctly, this can also cause the shop to remain empty even if the catalog is full of products.

    We typically see this when there are multiple catalogs in the account, and the shop page was attempted to be setup manually, rather than letting the setup wizard do its thing πŸ™‚

    The easiest way to tell if this might be the case is by navigating to the Product Catalog Manager and seeing if there are multiple catalogs created for a single store. Specifically, if there is a catalog name with the format “Products for <storename>“, then this suggests that the shop page was setup manually at some stage and may be linked to the empty catalog.

    If you only see one catalog though, and that’s the one with products already in it, then let’s wait and see! Could you let me know what you find?

    Cheers!

    Simon.

    Hello @skyverge, I can see two catalogs, one that was created manually with the name format β€œProducts for <storename>β€œ (empty catalog) and the one created by the plugin setup wizard (about 250 products).

    After deleting the β€œProducts for <storename>β€œ I have realized that this was the catalog linked to the store, that’s why my store was showing 0 products.

    I should also delete the catalog and setup again from the plugin wizard?
    (I can’t find any options under config of that catalog to link it with the Facebook page)

    Thank you!

    Hello @skyverge, I returned to the plugin, and found an option to link the catalog with the Facebook page. Now I can see from the Facebook page that the catalog is linked.

    I can see products listed! πŸ™‚πŸ™‚πŸ™‚

    Thank you so much, I’m very happy with you taking control over this plugin, the support they have before was awful, many months trying to communicate with both Facebook and WooCommerce and none of them was solving anything but blaming each other. Keep the good work!

    Plugin Author SkyVerge

    (@skyverge)

    Hey @danidub!

    Ah, that’s great news! Thanks so much for keeping me in the loop, and sorry for not replying sooner.

    That does indeed sound like you followed the correct process. The naming of the catalogs is a telltale sign that the manual setup was at least started prior to running the setup of the plugin, and that usually does cause an issue like this. The quick fix is to delete both the catalogs, and then run through the setup wizard once more to re-create the correct catalog and link everything up. Though it sounds like you were able to re-link the correct catalog to your shop page too, which is great!

    Thanks so much for the kind words too, we’ve still got a lot of work to do, though it’s very nice to hear that we’re having an impact both from support and development! πŸ™‚

    Is there anything else I can help out with today?

    Cheers,

    Simon.

    Hello @skyverge, no more help needed Simon!

    Thank you πŸ™‚πŸ™‚πŸ™‚

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Products not showing on shop tab’ is closed to new replies.