Support » Plugin: Custom Post Types and Custom Fields creator - WCK » products dropping out of their taxonomies

  • Resolved softsleepysounds

    (@softsleepysounds)


    Hi there,

    We have created taxonomies for ranges of our products – http://littlesnail.com.au/moulin-roty-ranges/ however we have been noticing that the products seem to drop out of the taxonomies at random times. I am not sure why.

    I first noticed this a few months ago and went through our product catalogue and put the products back into their ranges, but it has been happening again. This page http://littlesnail.com.au/moulin-roty-ranges/m-elle-ribambelle/ only has two products, but there are many more in that range, and I did go through all the products and make sure they were checked a couple of months ago.

    Could you help?

    Thanks and regards,
    Sarah

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Cristian Antohe

    (@sareiodata)

    Hi,

    This is most peculiar. However, while I don’t dismiss it, our plugin doesn’t take care of adding terms to posts unless you’re using the Front End Posting module from our Pro version.

    All we’re doing taxonomy wise, is telling WordPress that a particular custom post type can have terms from a particular taxonomy. The actual adding of terms to posts is still managed by WordPress.

    There are a few things that I can think of that could cause such an effect:

    * there is a database caching issue. Please try to disable any database caching if you can.
    * there’s a plugin that updates your posts from another place other then the default WordPress admin panel
    * something is wrong with the query that lists items on that page. I noticed all brands have a URL like this http://littlesnail.com.au/brand/bajo/ Notice the /brand in the url. The url you send is different: http://littlesnail.com.au/moulin-roty-ranges/m-elle-ribambelle/ Could it be there’s something miss-configured there?

    I’m sorry I’m not of much help. But I’ve personally haven’t encountered this type of bug. If I was to take a guess, a plugin or your theme lets you or automatically updates your shop items without saving information regarding terms.

    Hi Cristian,

    Thanks for your thoughts. It is an interesting problem, because we use the same system on another site http://www.playimports.com.au and haven’t had the same problem. Something you said about the misconfiguration of urls made me wonder if the problem might be that the taxonomy was called “moulin roty ranges” but the label was “ranges” / “range”.

    On the Play Imports site, the taxonomy is called ranges and the labels are the same. I have changed the taxonomy name, so hopefully that will help. I guess we won’t know until some time down the track, because after we go through all the products and put them into their ranges (drats!), it will take time to see if they drop out of their taxonomies again.

    I can’t see anything on our site that would affect database caching, or any other conflicting plugins, but hopefully this will be the solution.

    I hope you have a great day. Thanks!

    Sarah

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘products dropping out of their taxonomies’ is closed to new replies.